English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics
Options

5 Posts

09-25-2012

United States

6 Signins

47 Page Views

  • Posts: 5
  • Registered: ‎09-25-2012
  • Location: United States
  • Views: 47
  • Message 1 of 2

G570 Battery won't charge

2013-10-12, 10:21 AM

It started out as a message by that Lenovo Power Saver that I should manage the battery power and lower the performance to enhance the battery power, when I was charging it. I set it too enhance the battery life as it stated. And it charged fine. Few days later when I turned it on it would come on fine, although it was plugged in and would not charge. The light on the charger it self was amber plugged in. But, there was no light coming on at the laptop too show that it was charging, and also the icon on the computer should plugged in but it was not charging. I have down the power purge, bought a new battery and put that in but all I get is no icon shown that it is even charging. It doesn't turn on with only the A/C charger is only in or when it is out. The batteries have worked fine in there but, no charging so I can't charge the batteries to even use the laptop. Nothing charges.

 

What is wrong is it the A/C charge adaptor that needs to be replaced? I have already tried the battery getting a new one, but now there is no icon. Is it the mother board? 

 

I have one screw missing under the corner where the power input is but,I do not believe that is the problem.

It's funny that one battery shows icon plugged but not charging. And the other one doesn't even show the icon when even plugged in.  So, I'm thinking it maybe be the charger.

 

My warranty is up, and I'm not spending a bunch of money to get it fixed up.

Reply
Options

2834 Posts

08-01-2013

Bangalore

1326 Signins

47537 Page Views

  • Posts: 2834
  • Registered: ‎08-01-2013
  • Location: Bangalore
  • Views: 47537
  • Message 2 of 2

Re: G570 Battery won't charge

2013-10-16, 8:43 AM

Hi Tora,

 

Welcome to Lenovo Community Forums!

 

I’m sorry to hear that your G570 Laptop battery is displaying error message “Plugged in not charging” and even after changing it with new one the battery icon is missing in the Taskbar and when the AC Adapter is remove the computer will automatically turn OFF, this issue is hardware related the DC-In port may have become loose as the screw is missing, I would Strongly Suggest Calling Technical Support for Assistance as the issue persists even after changing the Battery.

Click here to open a link where you can select the country and get the exact contact support number. I’m sure they will be a great help.

 

Do post us back for further queries.

 

Best Regards

Shiva Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms