Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics
Options

9 Posts

11-06-2013

Houston

6 Signins

71 Page Views

  • Posts: 9
  • Registered: ‎11-06-2013
  • Location: Houston
  • Views: 71
  • Message 1 of 6

G580 Intel HD 4000 upgrade to Win8.1 - Device not working Plus Dolby device had to be unistalled.

2013-11-06, 6:45 AM

After upgrading my 64bit G580 Win8 to Win 8.1, I ran new drivers from Windows Update and Lenovo G580 Driver Matrix for Win 8.1. No Intel HD 4000 Win 8.1 driver. Intel device has bang in Device manager. Device not working. Default MS Video device driver. No bells and whistles.

 

I installed the Win 8.1 audio drivers and software for my audio device. After Win 8.1, restart has Dolby Audio V2 device discovered wizard. But all driver update paths fail there, even if I point to Have Driver and go to drivers folder. I unistalled this specific device V2 software at Programs control panel and it never discovered the Dolby device again. So, no bangs on that, but uninstalling the software seems like a bad workaround. Was V2 supposed to unistall with the driver update. Need to fix installer, Lenovo?  

 

Going through Device Mgr, Intel HD 4000 device has had a bang since upgrade to 8.1. Device not working.

Automatic, browse to driver say best driver installed- MS generic Video device. Update driver- Have Disk will install Win8 driver, asks to reboot and band is still in Device Mgr. Driver says it is the Intel device, but the message on the driver is Device not Working. No bells and whistles.

 

So, these two devices need new drivers/install packages.

 

Posted similar whining msg on TechNet.

 

I really need my Video to work correctly so my XP VM is not some pop-up sized window, et al. The VM was created later, so is irrelevant to issues, in fact I upgraded Win8.1 to Pro to get VM. 

 

Is there  a fix in the pipeline, or should I return the G580?

Reply
Options

2834 Posts

08-01-2013

Bangalore

1326 Signins

47537 Page Views

  • Posts: 2834
  • Registered: ‎08-01-2013
  • Location: Bangalore
  • Views: 47537
  • Message 2 of 6

Re: G580 Intel HD 4000 upgrade to Win8.1 - Device not working Plus Dolby device had to be unistalled

2013-11-07, 12:38 PM

Hi Rvgammill,

 

Welcome to Lenovo Community Forums!

 

I’m sorry to hear that your G580 Laptop display and Audio V2 is not working as expected and even after installing the exact driver for the computer generic driver is displayed in the Device Manager, I suggest you to install the drivers directly from Intel and NVIDIA, below are the link to automatically scan the computer and install the relevant driver from Intel and NVIDIA:

 

Then for the audio issue in the computer, please install the driver in administrator mode and check the issue. Below is the link to download the exact driver for Windows 8.1 and when installing the driver right click on the downloaded file and select “Run as administrator” option:

 

Hope this helps!!!

 

Do post us back if the issue still persists.

 

Best Regards

Shiva Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Options

9 Posts

11-06-2013

Houston

6 Signins

71 Page Views

  • Posts: 9
  • Registered: ‎11-06-2013
  • Location: Houston
  • Views: 71
  • Message 3 of 6

Re: G580 Intel HD 4000 and DolbyV2 upgrade to Win8.1 -

2013-11-07, 18:15 PM

Thank you, I was afraid of using a driver from Intel, as they warned to go to OEM. I will now update from their site. I was under the impression that HD 4000 was an alternate hardware config to NVidia, so I avoided it. The NVidia driver is in the Lenovo 8.1 matrix.

 

I had already updated the Conexant driver, as it was included in the driver matrix for 8.1. I assumed any required new Dolby it installed replaced the V2 and was notifying Lenovo Community to expect error and Lenovo engineers that the Conexant install package needed to uninstall the old V2 software.

 

Thanks again for your timely advice.

 

A last question: I am running an XP VM on the laptop for some old professional software applications. I tried to run the XP upgrades in the latest driver matrix, but none seem to recognize my Lenovo hardware. I assumed this was a quirk of VMs. I cannot get a full screen for the VM. Much reading about VMs has failed to point this out as a quirk, problem or notable event.

Reply
Options

9 Posts

11-06-2013

Houston

6 Signins

71 Page Views

  • Posts: 9
  • Registered: ‎11-06-2013
  • Location: Houston
  • Views: 71
  • Message 4 of 6

Re: G580 Intel HD 4000 upgrade to Win8.1 - Device not working Plus Dolby device had to be unistalled

2013-11-07, 18:32 PM

I am afraid your solutions are not applicable.

 

Intel does not detect my hardware as being Intel supported, and suggests OEM. Lenovo has no Intel HD 4000 drivers for 8.1. The 8.0 drivers do not fix Video issues, except to show hardware as HD 4000 in Device Manager, as opposed to default MS Video default device. Settings are unavailable for either.

 

Intel site link was to Auto detect feature, which refers me to OEM and does not give a driver. Been there, done that.

 

Nvidia site also does not recognize my hardware and reduces options to manually selecting a driver from entire catalog. I am loath to do that. Nothing in my documentation says I have an NVidia device. As Device Manager has always shown my device as Intel HD 4000 (even when the driver itself was default MS Video device), I am releluctant to manually select any NVidia driver.

 

Screen shot filess are "over 20,000 characters" so unable to post here. 

 

Best regards,

 

Vic Gammill

Reply
Options

9 Posts

11-06-2013

Houston

6 Signins

71 Page Views

  • Posts: 9
  • Registered: ‎11-06-2013
  • Location: Houston
  • Views: 71
  • Message 5 of 6

Re: G580 Intel HD 4000 upgrade to Win8.1 - Device not working Plus Dolby device had to be unistalled

2013-11-08, 15:50 PM

Also ran (as suggested) Lenovo's NVidia driver package on G580 driver Matrix for Win 8.1 and driver package install says no NVidia hardware detected. Just following up on the advice to install NVidia drivers, beyond going to NVidia site for Auto detect (which had failed.)

 

In the Win 8.1 driver matrix, there are also relevant BIOS updates, including one that kept Win 8.0 Intel HD 4000 drivers from being installed. But my computer came with Win 8.0 and the BIOS was up to date against all BIOS packages for Win 8.0 out of the box, so the most recent BIOS version is not my issue. (Perhaps it is a BIOS problem again?)

 

So, as before, Lenovo is notified that the Intel HD 4000 8.1 drivers need to be updated by Lenovo.

 

I like the G580, but need video to work correctly so my 32bit XP VM can be viewed running 32 bit database applications. Are the G580 Intel HD 4000 issues being resolved or should I return the G580 for a more usable computer?

 

Thanks again for your assistance!

Reply
Options

9 Posts

11-06-2013

Houston

6 Signins

71 Page Views

  • Posts: 9
  • Registered: ‎11-06-2013
  • Location: Houston
  • Views: 71
  • Message 6 of 6

Fixed! Finally!

2014-04-08, 5:38 AM

Intel installs 10.18.10.3496 version as of 4/8/2014 using their driver wizard.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms