Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics
Options

4 Posts

09-26-2015

India

7 Signins

78 Page Views

  • Posts: 4
  • Registered: ‎09-26-2015
  • Location: India
  • Views: 78
  • Message 1 of 2

G580 - USB 3.0 Ports - Unable to start - Code 10 - Lenovo G580 - Windows 7, 8, 8.1 & 10. Please help :-(

2015-09-26, 15:13 PM

Hi All.

 

I have been facing this issue since last two weeks.

 

I have Lenovo 580. Currently in Windows 7 - x64.

 

Suddenly both my USB 3.0 ports stopped working. I tested by inserting multiple pen drives, external hard discs and they weren't even getting the power.

 

When I go to Device Manager, under Universal Serial Bus Controller -> There is an exclamation mark next to : Intel USB 3.0 eXtensible Host Controller.

 

Read few posts here, tried installing all sorts of drivers from Lenovo, Intel.

Thinking that OS reinstallation would help, I installed Windows 10, 8.1, 8 & now in 7.

But the ports aren't getting the required power or detected. 

 

 

I am sure I am missing something. Can someone please help me or point me to the right direction to fix this ? :-(

 

Thank you in advance.

 

 

 

Mod's Edit: System model added to front of Subject line to improve visibility / clarity.

Reply
Options

6095 Posts

02-11-2012

Philippines

4459 Signins

274727 Page Views

  • Posts: 6095
  • Registered: ‎02-11-2012
  • Location: Philippines
  • Views: 274727
  • Message 2 of 2

Re: G580 - USB 3.0 Ports - Unable to start - Code 10 - Lenovo G580 - Windows 7, 8, 8.1 & 10. Ple

2015-09-28, 20:09 PM

hi icykash,

 

From the steps that you've tried, it does look like there's a hardware problem on the USB 3.0 ports (especially if you're getting Code 33 or 43 from the Device Manager).

 

 

Error codes in Device Manager

 

Last thing that you probably try:

1. Run the Hardware devices are not working  or the Diagnose and fix Windows USB problems tool from microsoft.

 

2. Shutdown the machine, remove the battery and unplug the AC adapter then hold the power button for 20secs (this drains any electric charge that's left on the machine).

 

When finished, plug-in the AC adapter and turn on the machine then hit F2 to boot into the BIOS. Once In the BIOS, hit F9 to load default settings then hit F10 to save and exit (this resets the hardware configuration of the machine to default).

 

When the machine boots back into Windows, check if the USB 3.0 ports are now working,

 

In case this still doesn't fixes the issue then I recommend you will need to send the unit for service.

 

Support phone list

 

 

Let me know if this works for you.

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms