cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 3,799

Question

I am currently using the G580 and facing some issues with the USB. When I attempt to plugin an USB devices such as memory devices, it detects it but unfortunately I am unable to browse the file.

 

Further checks revealed that there seems to be  no issues with other devices such as USB keyboard, mouse etc..

 

I formatted my machine and reinstalled my Win8. It started to work fine again but only up to a few days. Now the issue persists again. I tried reinstalling drivers from device manager but to no avail.

 

Could this be related to the hardware ?

Answer

One of our community users tried the method below and it seems to work. 

 

Try to uninstall the USB Drivers: Universal Serial Bus controllers list by follow the below steps:

 

  1. Go to the Device Manager.
  2. Double-click Universal Serial Bus Controllers to expand the list.
  3. Right-click on all of the drivers in the list and then select Uninstall.
  4. Close Device Manager and restart the computer.
  5. Reconnect the USB device that was having problems and test it to see if it works.

c03494461.jpg

Was this information helpful?