cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DeadMaue5
Paper Tape
Posts: 1
Registered: ‎08-01-2016
Location: US
Views: 325
Message 1 of 4

Lenov G50 Wifi Dropping

Hello I been having an Issue with my wifi it disconnects and I have to restart my laptop over and over I never had this issue before I had ATT before I move to and switch to TWC but not sure if its my provider. I have update drive the one I have right now is Qualcomm Atheros Communications (Qualcomm Atheros AR956x Wireless Network Adapter ).I dont know what to do anymore I need some help I am thinking it may be my laptop 

SeniorGuru
Posts: 2,383
Registered: ‎11-07-2014
Location: US
Views: 312
Message 2 of 4

Re: Lenov G50 Wifi Dropping

If it worked fine with AT&T then not with TWC it is the provider, not your notebook. Some provider supplied routers / modems are not very good and can cause all kinds of headaches with connected equipment.

I would suggest contacting the provider and have them supply a different router / modem to see if that clears up the issues for you.

Good luck.

CB

I do not work for Lenovo, I only provide suggestions based on my personal willingness to help others. All advice and comments are based on my experience, and do not reflect Lenovo policy, terms or conditions.
JDGillis
Bit Torrent
Posts: 3,251
Registered: ‎12-11-2015
Location: US
Views: 294
Message 3 of 4

Re: Lenov G50 Wifi Dropping

Try this and see if it helps.

 

Disable power mgmt for WiFi Card

 

  • Press Windows Key + R to open a Run window, or right click on Start and select Device Manager dirctly
  • In the Run window, type:  devmgmt.msc  to open Device Manager
  • In Device Mananger window, doubleclick on Network Adaptes to expand
  • Right click on yoru WiFi adapter and select Properties
  • In the Properties window, select the Power Management tab
  • Uncheck the box "Allow computer to turn off this device to save power"

 

Set WiFi Adapter power profile to Maximum Performance in Power Control Panel

 

  • Press Windows Key + R to open a Run window
  • In the Run window, type:  powercfg.cpl  and press enter to open Power Options
  • Click on Change Plan Setting for currently active plan
  • Click on Change advanced power settings
  • Scroll down to Wireless Adapter Settings, expand and set Power Saving Mode pulldown menu to Maximum Performance

 

Change the WiFi Channel used by your TWC Router 

 

TWC link on how to login to its Routers

http://www.timewarnercable.com/en/support/faqs/faqs-internet/homewifi/how-do-i-change-my-wifi-settin...

 

TWC - Top 10 Tips to Maximize Your Home WiFi Performance

http://www.timewarnercable.com/en/support/internet/topics/home-wifi.html

 

 

Good Luck!

 

 

Rusty99
Paper Tape
Posts: 1
Registered: ‎12-07-2016
Location: GB
Views: 193
Message 4 of 4

Re: Lenov G50 Wifi Dropping

I have tried all of the above methods and nothing worked. However I changed the router to 'WPA Auto' from 'WPA-PSK' and have no more drop outs for over a week. 

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors