English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics

1 Posts



1 Signins

16 Page Views

  • Posts: 1
  • Registered: ‎11-09-2017
  • Location: DE
  • Views: 16
  • Message 1 of 1

Lenovo B50-70 UEFI burned? (all Settings are read-only)

2017-11-09, 14:05 PM

Hello community,


I cannot change any settings in my UEFI on my B50-70 Notebook.

The last thing I installed was ubuntu, now I wanted to install Windows 10 again.

I cannot boot from any UEFI USB/CD/HDD anymore, it still has ubuntu as the only UEFI Boot entry.

It says "cannot boot ubuntu" all the time, but It doesn't accept any changes to the boot order.

Also removing the battery or the HDD doesn't change anything. It still wants to boot to the "ubuntu" boot entry.

Loading default settings does nothing. All settings are like before after reboot.

I still can boot in Legacy mode though, but I always need to hit enter to confirm the "cannot boot ubuntu" dialog.

I have the lastest UEFI Firmware installed (3.04 or so).


Now since I cannot change any settings or boot entries, I think the chip where all settings are saved is somehow burned in all the settings forever. I tried many EFI Boot sources, these work on all other notebooks/pcs, also they worked on this notebook before.


Is there any way to read out which .efi file it has set for the entry "ubuntu" from a legacy booted OS? So I could make a workaround by placing the Windows bootloader to the same path with the same filename.


Thanks in advance.

Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop