English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics
Options

1 Posts

10-23-2015

IoM

4 Signins

14 Page Views

  • Posts: 1
  • Registered: ‎10-23-2015
  • Location: IoM
  • Views: 14
  • Message 1 of 1

Lenovo G50-30 - No Network Adapter. Also an erratic, unusable touchpad

2015-10-23, 22:37 PM

For the last 2.5 weeks my laptop has not located any network adapters (apart from Bluetooth) and the touchpad has been unusable, the cursor just jumps around the screen, mostly around the edges and randomly opens dialog boxes.  No idea what has gone wrong.  

 

Tried system restores - no change, tried downloading and installing current WLAN and touchpad drivers from this site but no improvement, finally went to a full system recovery to start over but even that did not solve the issue.

 

In device manager under Network Adapters I can only see 'Bluetooth device (Personal Area Network)' and 'Bluetooth Device (RFCOMM Protocol TDI)'.

 

In device manager under 'Mice and other pointing devices' it shows 'Lenovo Pointing Device', claims it is working properly using Synaptics driver version 17.0.14.74

 

Any ideas?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete