English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics
Options

8 Posts

07-19-2018

ES

12 Signins

139 Page Views

  • Posts: 8
  • Registered: ‎07-19-2018
  • Location: ES
  • Views: 139
  • Message 1 of 12

Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-19, 9:35 AM

Hi! 

I have a laptop G50-70 I7 4510U, updated to W10. The problem is that the laptop doesn't turn on  if it is not plugged into the mains. But once switched on, I unplug the power and it stays on and it lasts about 2 hours

I tried a new battery and it does the same.

Could it be due to the error with the Intel Magnament engine driver?

I tried to update the driver from the Intel website, but it tells me that I already have the appropriate driver. 

 

Any suggestions?

 

Thanks a lot!

Solved! See the solution
Reply
Options

9994 Posts

11-30-2015

PH

6784 Signins

729904 Page Views

  • Posts: 9994
  • Registered: ‎11-30-2015
  • Location: PH
  • Views: 729904
  • Message 2 of 12

Re: Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-19, 21:18 PM

Hi Sdiaz,

 

Welcome to the Community Forums.

 

Intel ME runs only when the machine is sleep, booting or when running so there should not be any power issue related to it.

 

Start by draining some power, unplugging the mains and removing the battery, pressing down the power for 20 seconds. Place back the battery and use the Novo button to turn it on. Check if this would be the same. Repeat the same procedure without the harddrive and compare.

 

I would consider investigating the hardwares first so having it check with a service center should be ideal specially that you already tried a new battery and still having issues. 

 

Update us how it goes.

 

Regards

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

8 Posts

07-19-2018

ES

12 Signins

139 Page Views

  • Posts: 8
  • Registered: ‎07-19-2018
  • Location: ES
  • Views: 139
  • Message 3 of 12

Re: Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-19, 21:55 PM

 

 

Thanks for your help,
I comment, the issue of draining the residual energy, I've tried it several times, without result.
The Novo button does not work either. If I press it without the laptop plugged into the power supply, it will not start. Does the same thing by pressing the power button.
  Actually what it does is a start attempt, it turns on both LEDs and the one on the web cam, the screen turns black, the fan is heard, and it stops. But all this only lasts a second.
I was talking about the Intel ME driver, because I read that it runs at the windows start and the device explorer tells me that it has a yellow triangle "STATUS_DEVICE_POWER_FAILURE".
I tried to update the driver to version 11 and also to 9, but it is not solved.

Sorry, but I did not understand you well, tell me to remove the hard drive, and press the power button or the Novo button?

Thank you very much for your support.

 

Reply
Options

9994 Posts

11-30-2015

PH

6784 Signins

729904 Page Views

  • Posts: 9994
  • Registered: ‎11-30-2015
  • Location: PH
  • Views: 729904
  • Message 4 of 12

Re: Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-20, 13:48 PM

Hi Sdiaz,

 

Greetings.

 

Turn off the laptop.

Unplug the charger.

Press the Novo button to power on (item 2 page 9).

Check it the machine would turn on (with battery alone).

 

Try the same steps above without the charger (mains) and the harddrive.

 

This would help isolate hardware issue from the Intel ME driver and software issue.

 

Regards

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

8 Posts

07-19-2018

ES

12 Signins

139 Page Views

  • Posts: 8
  • Registered: ‎07-19-2018
  • Location: ES
  • Views: 139
  • Message 5 of 12

Re: Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-20, 14:04 PM

Hi again, only with the battery the Lenovo button does not turn on the laptop. It Do which described in the previous post. If I plug in the charger, and press Lenovo button, it turns on normally, but it does not show me the One Key recovery menu. Then I will try to take out the hard drive and I'll tell you. Thank you very much for your attention.

Reply
Options

8 Posts

07-19-2018

ES

12 Signins

139 Page Views

  • Posts: 8
  • Registered: ‎07-19-2018
  • Location: ES
  • Views: 139
  • Message 6 of 12

Re: Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-20, 18:24 PM

Hi, I'm here again. Well, I tried what you say ... No hard drive and only battery, Novo button does not turn on the laptop and the power button either. The laptop without a hard drive but with a charger, the Novo button turns on the laptop and displays the screens that are attached below. The power button does the same. I look forward to your comments. Thanks again.

Reply
Options

8 Posts

07-19-2018

ES

12 Signins

139 Page Views

  • Posts: 8
  • Registered: ‎07-19-2018
  • Location: ES
  • Views: 139
  • Message 7 of 12

Re: Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-20, 18:52 PM

I continue ... I have disassembled the optical unit, and the laptop only with a battery, it still does not start with a Novo button or with a power button. If I plug in the charger the laptop does the same as before. I enclose another photo because it only lets me add one per post.

Do I dismantle anything else? Any suggestions?

Best regards. 

Reply
Options

8 Posts

07-19-2018

ES

12 Signins

139 Page Views

  • Posts: 8
  • Registered: ‎07-19-2018
  • Location: ES
  • Views: 139
  • Message 8 of 12

Re: Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-20, 19:07 PM

I attached the last photo and I take the opportunity to tell you something in case it was important. For some time now ... when I turn on the laptop with the charger connected, it does a strange thing, it does the same as when I try to turn it on only with a battery, but after that second, it starts up. I apologize for not explaining myself well. But between the translator and this subject is a bit weird ... I'm getting a little crazy.

Best regards!

Reply
Options

9994 Posts

11-30-2015

PH

6784 Signins

729904 Page Views

  • Posts: 9994
  • Registered: ‎11-30-2015
  • Location: PH
  • Views: 729904
  • Message 9 of 12

Re: Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-20, 20:08 PM

Hi Sdiaz,

 

Greetings.

 

The info on the photo is just because the harddrive is not there to boot from. It would be gone once you place back the HDD.

I would rather have the systemboard checked regarding this issue with service technician. 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

8 Posts

07-19-2018

ES

12 Signins

139 Page Views

  • Posts: 8
  • Registered: ‎07-19-2018
  • Location: ES
  • Views: 139
  • Message 10 of 12

Re: Lenovo G50-70. Error with driver Intel Magnament engine

2018-07-20, 20:59 PM

Hello, I'll tell you about the tests I've done. I have disassembled the fan and the two RAM memories (it has two of 4 GB) I tried to start only with battery, but it does not turn on, neither with Novo button nor with power button. I have placed the fan and the hard disk, but without RAM, and it does not boot, but the LEDs are kept and the hard disk is listened to for 10 seconds and stops. I put all the elements back and continue doing the same as at the beginning. One thing I have noticed, that when placing the battery, I see a small spark when attaching the connector of the battery with the connector of the laptop. As if there was consumption being turned off. Which does not seem normal to me ... What do you think? Thanks again for your support.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save