cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Destamone
Paper Tape
Posts: 3
Registered: ‎04-27-2017
Location: ZA
Views: 877
Message 1 of 3

Lenovo G50-70 No Wifi

Hello,

 

i am a proud owner of a Lenovo G50-70 running on windows 8.1. i recently had an issue with my wifi not being able to turn on and i thought the drivers had an issue and so i downloaded the wifi drivers from lenovo website for my Quallcom Atheros adapter.They got installed well and upon rebooting my Pc the wifi icon had dissapeared and when i checked on adapter settings on the network sharing centre there were none either. The device manager showed the adapter having a yellow exclamation mark with code 10 error(device not starting up).I attempted to reisntall and it said device has upto date drivers. i attempted to reboot with the drivers unistalled and still same response.

I would appreciate any help to resolve this.

Support Specialist
Posts: 2,948
Registered: ‎02-22-2017
Location: GB
Views: 814
Message 2 of 3

Re: Lenovo G50-70 No Wifi

Hello

Thanks for using the Lenovo forums.


Try to download the WiFi and Chipset drivers for the unit from the support page.

 Make sure to reboot the unit after the update.

 

Hope this helps, let us know how you get on.


==================================================================================
Did someone help you today? Thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

 

This will help the rest of the Community with similar issues identify the verified solution and benefit from it.




Pesszimistának lenni a legjobb, vagy igazad van, vagy kellemesen meglepődsz...
Destamone
Paper Tape
Posts: 3
Registered: ‎04-27-2017
Location: ZA
Views: 797
Message 3 of 3

Re: Lenovo G50-70 No Wifi

hello,

Thank you for your response. i did download the drivers from the link support page you sent. i then uninstalled the existing drivers beginning from the installer on the control panel together with the one in the device manager(i deleted the software as well). The fresh install did not solve the problem, even after the reboot as suggested.Smiley Frustrated

Check out current deals!


Shop current deals

Top Kudoed Authors