Showing results for 
Search instead for 
Did you mean: 
What's DOS?
Posts: 1
Registered: ‎07-03-2017
Location: IT
Views: 1,857
Message 1 of 1

Lenovo G580 BIOS access blocked

Hello Everyone, Its a much discussed yet embarassing problem.


I have a G580 with intel i3 processor. The machine is quite old (5 years i think) and has been subject to various OS upgrades, changes, flashes, dual boots systems like ubuntu & windows.


Recently to upgrade the machine i bought an i7 processor (yes it is compatible, i checked the hardware manuals). Once installed  the display wont come on, i figured i needed a BIOS update. Thats where the terrible stuff started.


I tried using the BIOS update tool downloaded from the official lenovo website with windows 10. As soon as i launched it, the command prompt like window opened and my computer froze. That happned a few times. Figuring, it might resolve itself I left it alone for 3 hours but it was still frozen.


Also figuring that the tool is for windows 7 i ran it on compatibility mode. Still the same result.


I read on some forum a guy had the same issue and it was resolved by reverting to windows 7.


So i bought a new copy of windows 7 (yes i really want that i7 processor). Installed it and tried to run the tool. Still, it froze the minute the window opened (another 3 hour gesticulation time was given to he machine to unfreeze itself but in vain).


So i tried to access the bios to see if there was a supervisor password preventing me from entering. Thats when i discovered that i could nnot access the bios at all.


Ive attached some screenshots in the end to explain.


Startup: The screen i see when i power on

F2: The screen i see when i press F2 at the startup screen

F12 : The screen i see when i press the F12 on startup

Escape : The screen i see when i press escape on startup

Novo Menu : The screen i see when i power down and then hold the Novo button

App Menu : the second screen after pressing F12 on startup which on pressing enter takes me to the same screen as seen in the image Escape


I also tried checking for any jumper or CMOS clear option but all experts on lenovo forums keep claiming that theres no way to do it and there are no jumpers for BIOS access. (I tried removing the CMOS batery too, Nada). I also tried other things like Fn+F2 etc. Nothing worked. I also tried removing all EFI partitions and booting without a hard disc. Still, nothing. The same screens over and over.


So the possibilities that i can summarize are

1. There is a jumper and i cant find it.

2. Last time i sent the comput for repairs, the repair guy has played some trick on me blocking my access with an SVP. In which case i need to know how to get to this password prompt

3. I'm really dumb and have missed something very obvious

4. Its time to throw away the motherboard


Someone help!

F12.jpgF12Novo Menu.jpgNovo MenuStartup.jpgStartupApp menu.jpgEscape.jpgEscapeF2.jpgF2

Check out current deals!

Shop current deals

Top Kudoed Authors