cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Nathan41
What's DOS?
Posts: 1
Registered: ‎09-22-2016
Location: CA
Views: 1,028
Message 1 of 2

Wifi Issues on G50-45 after Windows 10 Anniversary Update

I have a Lenovo G50-45 laptop running Windows 10, completely up to date including the Anniversary Update. Since that update, my laptop is having issues staying connected to my home Wi-fi network. I have tried unplugging and the plugging back in the router (multiple times and lengths of disconnection time), and this does not fix the issue. My laptop stays connected to the Wi-fi for anytime between 10 min to 12-13 hrs (after being turned on), before losing connection. The network then shows up in Windows 10 as "secured", but it cannot connect. Often, restarting my computer can fix the issue, however, a few times I have been unable to connect at all for a couple hours. My laptop does not have any problems connecting to several other networks. However, on the Wi-fi where the connection problems happen, there are at least 2 other laptops and mobile devices that have absolutely no issues with the Wi-fi, leading me to believe that the issue is with my laptop. I have made sure the network adapter driver is up to date (downloading the latest one from the Lenovo website, not just asking Windows if it is up to date), and also used all options of Windows network troubleshooting. Any ideas?

 

I've also used the Windows 10 reset option (minus personal files), and after the reset, the problem persists.

 

Generating the WLAN report in the cmd prompt reveals that the sudden disconnects are caused by following threee reasons:

"The driver disconnected while associating" (count:148)

"The network is disconnected by the driver" (count:10)

"The specific network is not available" (count:28)

Sr Support Specialist
Posts: 8,165
Registered: ‎11-30-2015
Location: PH
Views: 993
Message 2 of 2

Re: Wifi Issues on G50-45 after Windows 10 Anniversary Update

Hi Nathan41 , 

 

Welcome to the Community Forums. 

 

You may try this solution

Else proceed with changing the WLAN property in device manager to uncheck power management and setting aggressive mode similar to this article

 

Update us how it goes.

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Check out current deals!


Shop current deals

Top Kudoed Authors