cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
markwills
Blue Screen Again
Posts: 1
Registered: ‎04-26-2015
Location: germany
Views: 884
Message 1 of 2

lenovo g510 stuck in lenovo splash screen

I bought this g510 less then a year ago without an OS.
I've installed win7 first then ubuntu14.04, back when i get it.
Yesterday I deleted my win7 partition and reinstalled a premium sp1 win7 version from a usb formatted as NTFS - as you might have guessed I'm booting the laptop in legaci mode. The installation got stuck and failed and i had to do a hard reset.
After the hard reset the laptop won't boot and in fact it won't even pass the splash screen or respond to fn+f2 or any other shortcut to get into the bios. Even when i shut it off and press the Novo button it starts but doesn't display the blue utility menu with bios and boot options. Ive tried pressing the power button for 30 seconds witn the battery and power cable disconnected and tried to boot from usb but still nothing.
I then took the hard drive out and the laptop would boot and respond to novo button and fn+f2 and i can go into bios. It would also boot from usb when the hdd is disconnected. But it dosen't matter which bios settings i change or if the bootable usb is connected, when i hook the hdd back the laptop will just get stuck on lenovo splash screen again and won't respond to Novo button or fn+12 and it won't boot from usb - i should mention it does respond to capslock or the key to make the screen black (fn+f9).
I have a 1TR samsung sata hdd that seems to be perfectly fine. I don't think its the hdd or any of the hardware and the symptoms are not of defected hdd or anything else i've seen before. It 's also not a uefi problem as i've tried legacy and uefi mode with the same results. Also my usb boot is enabled in the bios just in case you're wondering.
This has ruined my weekend and about to ruine my week. Help lenovo please save me....?!?
Social Support Agent
Social Support Agent
Posts: 5,822
Registered: ‎02-11-2012
Location: PH
Views: 863
Message 2 of 2

Re: lenovo g510 stuck in lenovo splash screen

hi markwills,

 

Welcome to the Forums.

 

If using another drive works fine on the G510 then I suspect that the stock HDD is failing or has corrupt partitions.

 

Can you consider using a 2.5" SATA enclosure to convert the stock HDD into an external drive and try to format the drive and/or run a hardware scan on it using the following:

 

  - Lenovo Storage Test or

  - HD Tune.

    - http://www.hdtune.com/faq_1.html

 

When finished, try to insert it back on the G510 and observe.

 

If you get errors on the scan or if the above step is not possible, I recommend you contact warranty support on how to go about getting the unit serviced.

 

Support phone list

 

Similar thread:

G500 stuck on lenovo screen

 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Check out current deals!


Shop current deals

Top Kudoed Authors