English Community

Lenovo NotebooksLenovo B and G Series Notebooks
All Forum Topics
Options

1 Posts

09-17-2017

US

1 Signins

22 Page Views

  • Posts: 1
  • Registered: ‎09-17-2017
  • Location: US
  • Views: 22
  • Message 1 of 4

lenovo g585 won't boot

2017-09-17, 20:43 PM

I'm troubleshooting a lenovo g585. 

 

It won't boot.  

  • I've tried removing the power, battery, and holding the power button.
  • The battery is charging.  The light was initially flashing red, it's gone white, and it seems to have charge even after the cable is pulled.
  • When the power button is pressed, power and battery are white.
    • The fan turns on.
    • It tries to access the optical drive.
    • No bios, no splash, screen stays black.
    • After a few seconds power light turns off, battery light blinks, and I'm back to square one.
  • I've pulled the drive and attached it to an external drive unit.  Drive spins up fine, is fully accessible, and no sign of any errors or issues.

 

Do you guys have any ideas?

Reply
Options

180 Posts

11-28-2016

GB

138 Signins

2083 Page Views

  • Posts: 180
  • Registered: ‎11-28-2016
  • Location: GB
  • Views: 2083
  • Message 2 of 4

Re: lenovo g585 won't boot

2017-09-18, 13:57 PM

Hello Juridain

 

Thank you for using the Lenovo forum

 

Have you tried using the novo button on the unit, If the device is powering up and not bookting it may be the OS on the unit. Trying doing a factory reset on the unit as if this is an OS issue that should solve it.

Reply
Options

1 Posts

12-09-2017

BW

1 Signins

23 Page Views

  • Posts: 1
  • Registered: ‎12-09-2017
  • Location: BW
  • Views: 23
  • Message 3 of 4

Re: lenovo g585 won't boot

2017-12-09, 17:15 PM

i have tried the novo and remove battery power down solution still im getting a black screen

Reply
Options

4 Posts

05-21-2019

AL

4 Signins

74 Page Views

  • Posts: 4
  • Registered: ‎05-21-2019
  • Location: AL
  • Views: 74
  • Message 4 of 4

Re: lenovo g585 won't boot

2019-05-21, 8:40 AM

Hello there, i am haveing a similiar problem  i have a lenovo g585 and it had been stuck to the lenovo splash screen and i cant do nothing. I cant use and F1 up to F12 and or delete because it doesnt do nothing i cant access anything. I tried with battery nothing worked i saw in a forum to use the novo button to pres it 10 times and on the 11 time press it for 20 sec and it opened a menu with 4 options i opened used the laptop but than when i turned it off it doesnt open anymore i cant open boot page i cant see windows logo nothing i do seems to matter, can you please help me get a fix

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save