Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Posts: 54
Registered: ‎07-23-2010
Location: USA
0 Kudos
Accepted Solution

HELP!!! Impossible to enroll any fingerprint with BioExcess

[ Edited ]

Please HELP!!! Smiley Frustrated

I have a IdeaPad V370 and I installed BioExcess v7.0.67.0 with EgisTec driver v3.0.10.4 (on Device Manager is shown v3.0.7.0).


When launching BioExcess initial wizard, on "Fingerprint Enrollment" phase, after logon password, where I should enroll 2 fingers with their fingerprints I ALWAYS GET AN ERROR. At the last 6 fingerprint of the same finger (I tried also with different fingers, same result) it always gives me error, so I can't complete the process at any circumstances. I reinstalled the driver and the software from V370 support page but the result is the same. I searched for another, newer, driver with no success.


I tried to install Windows hotfixes KB974476 and KB978258 listed near the fingerprint driver. But no success, both installations are aborted with "The update is not applicable to your computer".


Please give me a solution for this software to work. I want to use it, for safety reasons, not to disable/uninstall it. THANKS!!!

Posts: 955
Topics: 3
Kudos: 80
Solutions: 65
Registered: ‎01-05-2010
Location: INDIA

Re: HELP!!! Impossible to enroll any fingerprint with BioExcess

As I understand you have issue with using Fingerprint reader.


Kindly unistall the driver and software ( BioExcess )


Restart the laptop and then install the Fingerprint reader driver and then BioExcess software without restarting the laptop.


After this check the issue should get resolved.


Best Regards,


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Posts: 54
Registered: ‎07-23-2010
Location: USA
0 Kudos

Re: HELP!!! Impossible to enroll any fingerprint with BioExcess

[ Edited ]

Thanks for the support.

The correct solution is to uninstall the EgisTec driver and the BioExcess software, than to install first the BioExcess, restart the PC (BioExcess compulsory requires restart in order to launch) and to reinstall the driver without restart. Launch then BioExcess, and the fingerprints enrollment works just fine.

Thanks again. I think that such info must become known to all owners of V370, V470, V570 etc.