cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
zenalc
Fanfold Paper
Posts: 3
Registered: ‎01-26-2019
Location: US
Views: 286
Message 1 of 3

Lenovo M5400 weird battery bug

Hi everyone, 

 

A few months ago, my laptop developed a LCD issue where it would show 3-4 different vertical lines. Thinking it may have been the display flex cable, I ordered a replacement on Amazon and replaced it, but to no avail. A few days after, I ordered a new replacement LCD and voila, it was fine again. 

 

Now, here's the very weird thing that has been driving me through the roof. Ever since I replaced my LCD, my laptop refuses to indicate that it is charging when plugged in. Peculiarly, when Windows didn't indicate that it was charging, the laptop's battery percentage would raise as if it where charging.. but after a few minutes, the laptop would just shut down with the fans running at full speed. And the only way I would've been able to stop the fans from running was by unplugging the battery and plugged it back in after a few seconds. 

 

Also, sometimes it will detect that it's plugged in, but will forever say that it's 'plugged in, not charging.' I waited hours, thinking it must've been a calibration issue, but it would be stuck there at plugging in, not charging. 

 

I have tried removing the battery, pressing the power for 30 seconds, and then plugging the battery and charger in, but to no avail.

I have tried deleting the Microsoft ACPI driver and scanning for hardware changes, but to no avail.

I have tried booting Linux on this laptop, and it too doesn't say that the laptop is charging, and if it detects it, the percentage never goes up and it shows an abnormally long time estimation for it to charge.

 

So far to charge, I have to do weird things like wait for the laptop to not say its plugged in, then disable the ACPI driver for a few minutes, and sometimes on renabling it, it will start to work. Or if that doesn't work, I have to completely shut down the laptop and wait for it to charge. 

 

So, yeah I have no idea what's happening. It charges when shut down completely (not sleep), and sometimes charges even while in use but laptop won't acknowledge it, and after a few minutes it shuts off regardless. 

 

I know this is an older laptop, but any help would be appreciated as budget is tight.

 

Thanks a lot.

zenalc
Fanfold Paper
Posts: 3
Registered: ‎01-26-2019
Location: US
Views: 248
Message 2 of 3

Re: Lenovo M5400 weird battery bug

Anyone?

zenalc
Fanfold Paper
Posts: 3
Registered: ‎01-26-2019
Location: US
Views: 238
Message 3 of 3

Re: Lenovo M5400 weird battery bug

Alright, so looks like support is dead for my laptop... probably because the laptop is an older model, and probably because Lenovo would rather fix issues with their newer laptops under warranty. 

 

For anyone having this problem, here's a semi-fix that works for me.

 

  1. Shut down your laptop fully by holding power button.
  2. Unplug your AC Adapter (if it's attached)
  3. Remove your battery
  4. With battery and adapter removed, hold power button for about a minute.
  5. Plug battery and adapter back in.
  6. Reboot.
  7. It shoud now hopefully charge...

Now, I don't know if it's an old battery that's causing the issue, or if I did something to my laptop while reinstalling my screen, but oh well. It is a laptop that's 3 years old now. 

 

Might have to just get a Macbook next time. 

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors