English Community

Lenovo NotebooksLenovo C, E, K, M, N and V Series Notebooks
All Forum Topics
Options

3 Posts

01-10-2019

GB

7 Signins

84 Page Views

  • Posts: 3
  • Registered: ‎01-10-2019
  • Location: GB
  • Views: 84
  • Message 1 of 2

Lenovo V110-15ISK power button not working

2019-01-10, 13:38 PM

I have a Lenovo V110-15ISK where the power button does not appear to work, but if I remove and reinsert the power cable the laptop will open up the Novo Button Menu and I can boot to the hard drive from there - from that point the laptop will work fine. 

 

Pressing the Novo button itself will not turn the laptop on.

 

This is a work laptop so I have other laptops I can get spares from, so I've replaced the power button component, the cable, and the motherboard entirely, but the problem still persists.  Pressing the physical power button component while I had the case opened up also did not work, so I don't think it is anything to so with the plastic power button not connecting to the component.

 

I've noticed that these Lenovos will not power on if they are sat on another Lenovo laptop (no idea why that is) so I'm wondering if whatever causes that effect could be affecting this one too, even though it is not stacked on another laptop.

 

Any suggestions or advice gratefully received.

Solved! See the solution
Reply
Options

3 Posts

01-10-2019

GB

7 Signins

84 Page Views

  • Posts: 3
  • Registered: ‎01-10-2019
  • Location: GB
  • Views: 84
  • Message 2 of 2

Re: Lenovo V110-15ISK power button not working

2019-01-10, 17:26 PM

I think I've fixed it...

 

Novo seemed to be a common theme in the problem so I've replaced the Novo button component and the laptop is now booting up with the power button as it should. 

 

I'm not sure if that component was broken and interfering with something, or if I've just nudged something by messing around, but it's working now :)

 

 

Update - I tried the component in another laptop and it had the same effect, but as soon as I took out the cable from the Novo button, the power button started working as normal, so confirmed that the Novo component was at fault.

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete