Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 1
Registered: ‎02-23-2019
Location: US
Views: 356
Message 1 of 2

Lenovo V310-15ISK second hdd in caddy not working

Recently I decided to upgrade my laptop to a new SSD(default hard drive is a Western Digital 1TB). But I wanted to keep the default HDD as additional storage and for that i also bought a HDD caddy. I installed Windows 10 on my new ssd after replacing the old hdd with it and tried to connect the HDD through caddy in optical bay. And here all the problems started.
1. Most of the time the PC stucks at the Lenovo sign when trying to boot with the HDD in the caddy
2. If it boots (1 out of 10 times) the HDD is not recognized by windows
3. However if I reinstall the IDE ATA/ATAPI controllers driver, first time i restart the computer, the HDD works just fine, it's recognized and it's accessible. But after a new restart the  problems 1 and 2 are reoccuring.
The BIOS sees the HDD connected.
I tried lots of tutorials, steps, tools but nothing seems to work. The caddy was tested on another laptop with my HDD in it and it works just fine(so it's not a caddy problem neither an HDD one).
I saw another similar topic here but it hasn't been updated since March 2018.
Any clues on this? Is there any size limitiation for a caddy with HDD  in optical bay for this model? Is there any patch that can help with this problem? Any info would be really appreciated.

What's DOS?
Posts: 2
Registered: ‎06-27-2019
Location: RO
Views: 123
Message 2 of 2

Re: Lenovo V310-15ISK second hdd in caddy not working



check the registry values for 


Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorAC\Parameters\Device (iaStorAC or iaStorA or iaStorV or iaStorAVC depending on driver)


Controller0Phy0DIPM     REG_DWORD       0         (Controller 0 Disk 0 Device initiated power management)

Controller0Phy0HIPM     REG_DWORD       0          (Controller 0 Disk 0 Host initiated power management)

Controller0Phy1DIPM     REG_DWORD       0         (Controller 0 Disk 1 Device initiated power management)

Controller0Phy1HIPM     REG_DWORD       0          (Controller 0 Disk 1 Host initiated power management)


Setting them to 0 disables the feature, some caddy don not work well with this.


Also try disabling Link Power Management


Worked For me Smiley Wink


Check out current deals!

Shop current deals

Top Kudoed Authors