Showing results for 
Search instead for 
Do you mean 
Reply
Ctrl-Alt-Del
Posts: 13
Registered: ‎10-13-2013
Location: Romania
Message 1 of 4 (1,474 Views)

Unable to use Intel 530 SSD with M5400

[ Edited ]

Hello! 

 

I finally decided to write over here, after reading and viewing a lot of forums lately on this subject. 

 

Context: 

I have an Lenovo M5400 (but don't think this is definitory to the problem, as I've seen that the same simptoms seem to exist to other lenovo models as well) with the SSHD drive. I bought an Intel 530 SSD (don't think the brand mathers either) and wanted to replace the SSHD with it. 

Upon replacing the original drive with the SSD, in order to make a clean windows install, the Windows 8 installer is unable to correctly detect my drive. 

The drive is visible in the BIOS (at times?!) and seems to interfere somehow with the booting process, as sometimes, the boot stucks with a blank screen and the green light of the drive is on permanently. (this doesn't happen all the time). 

 

What I tried: 

1) At first, I had the drive unitialized: no GPT or MBR, no partitions on it. I tried to install it as such, but failed. It was not visible to the Windows installer, only in BIOS, in the boot order, I could see it. This was done in BIOS legacy mode. 

2) I tried loading drivers in the Windows installer, via the "Load driver" option, when you get the message "W couldn't find any drives" or something like that. That was unsuccessful with the following: a) lenovo ahci drivers, from the online driver store, b) my previous windows drivers, which I took on a USB stick, c) some drivers from intel site.

3) At this point, the Intel firmware update bootable tool was not seeing my drive either.  

4) I then initialized my drive by connecting it via a SATA-to-USB cable to my computer and repeated step 2), with no success still. I initialized it as MBR but I doubt that initializing it as GPT would have made a diffrence. I tried both with creating a primary and active partition and with leaving the drive initialized with all the space unallocated. No success. 

5) I tried to update lenovo BIOS, because I suspect it's the cause of the problem, but was unable to do so. Downloaded the bios utility but it gives me an error "Bios folder ... ". With the bootable bios cd, it doesn't work: it doesn't boot. Has anyone managed to flash a newer bios? There is one posted on 09/30/2013 on the site, and my current one is 09/26/2013, as shown in BIOS. 

6) I then fiddled with various BIOS modes: uefi, legacy, both with priority, but with no success. 

 

At one point, I managed to see the drive in the windows installer, it was in UEFI mode only, with WIn 8 Optimized defaults ( I think) but I feared that it was just a single happening and didn't do anything, instead tried to see which settings worked in order to be able to reproduce this. I completly lost my chance, as after that, I didn't see the drive again in the windows installer. When it worked, I didn't have to load any driver. It saw it as MBR and prompted to format is as GPT, in order to use with UEFI booting. 

 

The things I noticed: 

On some occasions, in the bios boot order menu, the drive is identified as an Intel ssd, and on others just as an generic ATA HDD. I think there is a bad link between those two. When I reboot, restart, on some occasions I see it as the Intel drive and on others as the generic one. I think that in the case of generic drive, the windows installer has no chance on recognizing it. 

When it is seen in the bios though, I get all sort of problems when trying to boot a CD or USB, as it seems to ignore them and get stuck in the boot process. I think that in this situations it correctly detects the SSD, if I were to look in the BIOS. But when I try to boot the CD or the USB in these situations, it just stucks with the green drive light permanently on, and with the CPU working on something ( I hear the fans starting) and the boot stops here indefinetly. I have to restart, and then, depending on the case, I get the same results, or I can boot the CD but don't find the drive. 

I don't know by what chance I managed to "capture" it once in the windows installer but think this should be the common case. 

 

After all these, what I suspect is that the Lenovo BIOS is broken somehow. It messes up with the boot order, because although I have priority for the DVD, the boot gets stuck on trying to do something with the SSD, as described above. 

 

I am in the situation of returning the SSD back to the shop, as it is unusable with the current Lenovo m5400 motherboard/bios or whatever other hardware interferes with making it properly work ( ahci controller?). 

I am very upset by this, and have seen that on these very boards, there are other posts as well, not on this model, but on other lenovo models, with the same scenarios and simptopms as mine, which didn't get any solution. 

 

So, is there an answer to my problem? To update the BIOS? How to make the BIOS to not mess up with the boot order and get stuck? I tried all the possible combinations with no success and it's really frustrating. 

 

Another update: 

A lot of people seem to be having problem with the particular Intel 530 SSD. So this issue may not be related only to the motherboard/bios. I will post links to the corresponding threads from the intel boards: 

 

https://communities.intel.com/thread/49389?start=15&tstart=0

https://communities.intel.com/thread/52959

https://communities.intel.com/thread/51111

 

Does anyone have any idea or hint if using other software for initializing the SSD than Computer Management/diskpart is of any help? Like EASUS partition manager or Gparted? Maybe the disk isn't partitioned correctly. 

 

The disk isn't detected as an Intel SSD with the SATA-to-USB cable, instead being masked by it. Maybe this is another problem?

 

 

 

 

Ctrl-Alt-Del
Posts: 13
Registered: ‎10-13-2013
Location: Romania
Message 2 of 4 (1,412 Views)

Re: Unable to use Intel 530 SSD with M5400

Update:

I 'downgraded' my BIOS from 2.01 version ( released 09/25/2013) to 1.04 ( 08/08/2013) and still no new results. That seemed not to influence the visibility of the SSD. 

I downgraded using the 1.04-1.02 bootable CD. I hope that this doesn't have any side effects. 

 

Does anyone know how can I get back to the 2.01 version, in case it would be useful? 

Blue Screen Again
Posts: 2
Registered: ‎03-29-2015
Location: Sweden
Message 3 of 4 (797 Views)

Re: Unable to use Intel 530 SSD with M5400

Hello! I have the same problem as you. 

 I tried  to connect OCZ Vertex 2 60GBSSD but I failed. It has the same conntroller SandForce but the older generation. 

Maybe that's the problem?

 

I was unable to install it on Windows 8.1, when I switched to the BIOS to ACHI mode Capability mode. But later he again loaded with it, then the BIOS will not see it to be.

I think the problem in the BIOS! I have 2.03 the latest. 

Blue Screen Again
Posts: 2
Registered: ‎03-29-2015
Location: Sweden
Message 4 of 4 (709 Views)

Re: Unable to use Intel 530 SSD with M5400

Will you solve this problem?

Top kudoed Authors
User Kudos Count
1
1