English Community

Lenovo DesktopsLenovo Desktop Towers Knowledge Base

How can I set NumLock default to "On" at boot-up?

Question

Can anyone tell me how to get the NumLock to default to "on" at boot-up?

 

I've got a H530 desktop running Windows8.1, so no BIOS (as such), and I can't get the NumLock to come on when it boots. I keep getting my password wrong as I seem incapable of remembering to switch it on each time I log in.

 

Is there a way to change it?

 

Answer

There is a way as recommended by a community user to do it through registry, however, there is a risk and may mess up the system if you do not carry it out carefully. Please ensure you have enough knowledge about registry, and know what you are doing. 

 

To set NumLock to a default 'On' at boot-up, get to your system's  registry - the "InitialKeyboardIndicators" value has to be set to "2".

 

Ensure that you are accessing/ changing settings for Default users. 

 

  • Press Win + R and type in Regedit
  • Navigate to HKEY_USERS\Default\Control Panel\Keyboard
  • Right click on the “InitialKeyboardIndicators”, select Modify and change Value data to 2.
  • Exit Registry.
  • Reboot.

 

 

 

Was this information helpful?

Yes No

Comments

indirect On 2014-03-02, 19:23 PM

I have a new T540p.  Running Win 7.

 

Also want Numlock on at boot.

 

My: HKEY_USERS\Default\Control Panel\Keyboard>InitialKeyboardIndicators” = REG-SZ  2147483648

 

Should I change the value to "2"?

koudy_cz On 2014-03-07, 9:17 AM

Hi, I have Edge E531, and I had the same number as you, then i changed it to "2", and it all works fine!
So you have not worry about it. Anyway it's always better to do a registry backup, it's very simple, just click on File from the menu bar, and then Export, save somwhere, where you can find it later. And now you can modify registers as you want (with caution of course), and if something went wrong, you can Import back the "good" version.

bob1944 On 2014-03-29, 16:44 PM

I've got  a g510 with the 2147483648 data also, changing it to just 2 worked fine for me also on the num lock  - but the bottom left START icon dissapeared so I could not access the desktop. It reapeared after I hit the windows key - strange - but that's WINDOWS!

bob1944 On 2014-04-02, 8:44 AM

NO! - this definitely does not work on the G510 laptop.

Changing the value of 2147483648  to just 2 the num lock booted to on on the first reboot only on future boots it defaulted to off even though the value was still 2.

It seems to cause other problems also!

Surely there must be a fix for this?

jotthaah On 2015-03-25, 10:28 AM

On my ThinkPad E545 it worked.
I changed the reg key

HKEY_USERS\.DEFAULT\Control Panel\Keyboard -> InitialKeyboardIndicators to "2", and after reboot, the Num is locked now. This remains also after pressing the Win button, but only after 2nd reboot! (After 1st reboot, the WIN botton unlocked the NUM button...)

 

catmouse On 2015-10-05, 22:04 PM

Can some one help how to reset the bios settings on the lenovo flex 2.14 model no 20404  touch screen all the set up step by step guide  in stages to get it working again back to normal tryed the reset but no it went back to the page its stuck on boot menu  1 windows boot manager    2 ata hdd disk  3 pci lan efi network (ipv4)  4 pci lan efi network (ipv4)  windows 8  and theres no disck drive with this model 

catmouse On 2015-10-05, 22:05 PM

step by step on the confiuration guide need and  security  boot and exit mode wat are the settings supose to be 

NexusD On 2015-11-20, 17:43 PM

>> I've got a H530 desktop running Windows8.1, so no BIOS (as such)

 

This is an odd statement. According to the user guide for the H530, you enter the BIOS by pressing F1 repeatedly as your computer initially boots up.

 

>> Can anyone tell me how to get the NumLock to default to "on" at boot-up?

 

Yes, go into the BIOS and do that!

gicla On 2016-06-01, 8:18 AM

Hello All,

 

my Lenovo T450 doesn't have a configurble value like "Bloc Num at boot" into the BIOS and of course changing the registry key doesn't help if you need Bloc Num ON before the boot.

Is there a solution for that?

 

Thanks

Claudio

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Delete