cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
praziquantal
What's DOS?
Posts: 1
Registered: ‎03-26-2015
Location: usa
Views: 392
Message 1 of 3

Black screen with new GPU

I just purchased a K450e and upgraded it with an SSD, 650 watt PSU, and Radeon R9 290.  Unfortunately, after installing the GPU, I get only a black screen.  I've been through previous posts and disabled secure boot and switched boot mode to legacy.  Still nothing.  The onboard graphics work if I take the card out, but when I put it in, I get no output from either.  Any help??

Retired Support Specialist
Posts: 4,447
Registered: ‎04-22-2013
Location: Philippines
Views: 356
Message 2 of 3

Re: Black screen with new GPU

Hi praziquantal,

 

Have you tried toggling the BIOS switch on the r9 290.

 

See the Details below from 

http://www.guru3d.com/articles-pages/radeon-r9-290-review-benchmarks,15.html

 

 

Spoiler

The AMD Radeon R9 290 and 290X comes flashed with two separate BIOSed for testing. The bios can be toggled by the small black switch located on the top of the part closest to the mounting bracket that you plug your displays into. You must reboot after toggling the switch for changes to take effect.

Hope this helps

Cheers!

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Harelin
What's DOS?
Posts: 1
Registered: ‎03-30-2015
Location: CA
Views: 330
Message 3 of 3

Re: Black screen with new GPU

I am having this exact same problem with a GeForce GT 610 on my new K450e. Have you been able to find a solution yet?

Check out current deals!


Shop current deals

Top Kudoed Authors