cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
RRDave
Paper Tape
Posts: 2
Registered: ‎08-28-2013
Location: Texas
Views: 6,440
Message 1 of 9

H520 with ATI Radeon Graphics card

I have an H520 (with a 700W replacement supply) with i7-3770 CPU running Windows 8 that does not recognize the ATI Radeon HD 7790 card that I've installed.  If I set the BIOS to IGP as the default display device  I can view Device Manager using the onboard graphics port, which only shows the Intel onboard graphics.  Running the ATI Catalyst driver manager fails since it does not see the 7790. 

 

If I set the BIOS to AUTO or PCIe  I do not get any display on either the onboard or the 7790 graphics ports, so I have to physically remove the card to allow the machine to boot up again to use the onboard graphics by default to see the display again.  The sequence for AUTO prioritizes the PCIe display first according to the BIOS description, so apparently the onboard display does not get activated for this BIOS setting when the 7790 is installed.

 

As described in some other graphics card posts, I tried setting OS Optimized Defaults to disable but this had no apparent effect.

 

BIOS is Rev ESAKT23A.

 

I've tested the 7790 on an old computer and verified that it is working.

 

How can I get the 7790 to be recognized on the H520? 

 

Social Support Agent
Social Support Agent
Posts: 5,824
Registered: ‎02-11-2012
Location: PH
Views: 6,434
Message 2 of 9

Re: H520 with ATI Radeon Graphics card

hi RRDave,
 
Welcome to the Forums.
 
Your problem might be similar to this thread (this is for a K430 dssktop but same aspects apply). Try the fix that ParadiseDecay have posted as other users found it helpful.
 
The solution was to set the following in the BIOS:
 
Security Tab:
Secure Boot = Disabled
 
Boot Tab:
Boot Mode = Legacy (if applicable)
Boot Priority = Legacy First (if applicable)
CSM = Enabled
 
 
Hope this helps



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

RRDave
Paper Tape
Posts: 2
Registered: ‎08-28-2013
Location: Texas
Views: 6,400
Message 3 of 9

Re: H520 with ATI Radeon Graphics card

After making your proposed changes I had a failure to boot with an error 1962, which I believe was due to Boot Mode = Legacy, but the good news is that there is now an output from the Radeon HD7790 with the following BIOS settings:

 

Display=AUTO

Secure Boot=Disabled

CSM=Enabled

Boot Mode=Auto

Boot Priority=Legacy First

OS Optimized Defaults=Enabled

 

Thank you so much neokenchi, this problem has been haunting me for a couple of days!

Social Support Agent
Social Support Agent
Posts: 5,824
Registered: ‎02-11-2012
Location: PH
Views: 6,395
Message 4 of 9

Re: H520 with ATI Radeon Graphics card

hi RRDave,

 

Thanks for posting back your findings. This will help other users who are experiencing the same issue.

 

The Error 1962 "No Operating System Found" is probably due to the Boot Sequence (unit is booting from a non-bootable device). Kindly check under the Boot Tab > Primary Boot Sequence and ensure that the HDD is set as first boot. If this doesn't work, the OS is most likely locked in UEFI mode. (changing the Boot Priority to Legacy First must have caused this).

 

To fix it, try the following:

1. Undo the changes that you made in the BIOS and create a recovery drive.

2. Change the BIOS settings back where the ATI card worked and use the recovey drive that you created in Step 1 to restore the OS/ Alternatively, you can press F2 during boot-up to restore the unit to factory settings. (while Boot Priority is set to Legacy First).

 

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

elvis334
Paper Tape
Posts: 2
Registered: ‎02-07-2014
Location: USA
Views: 5,217
Message 5 of 9

Re: H520 with ATI Radeon Graphics card

This also worked for me with a Lenovo H515
FIRST make recovery thumbdrive just in case.

reset press F1

Display=AUTO

Secure Boot=Disabled

CSM=Enabled

Boot Mode=Auto

Boot Priority=Legacy First

OS Optimized Defaults=Enabled
(if it is not mentioned = do not change)

save and exit

turn off comp

installed pny nvivia gt430

turn on comp (I have picture!!)

install new drivers from PNY

ChazzMatt
Paper Tape
Posts: 2
Registered: ‎05-23-2014
Location: Atlanta, GA
Views: 4,724
Message 6 of 9

Re: H520 with ATI Radeon Graphics card

As noted, this also works with the Lenovo H515 series (10125)

ADDING nVidia GeForce GT-430 video card (graphics card) (display adapter)

__________________

 

THANK YOU!

 

I went through the hassle of registering with this site, just to say thank you to people in this thread who helped me figure out how to install a GeForce GT-430 in my elderly parents' Lenovo H515-10125 desktop computer.

 

I've built computers from scratch before and refurbished many others, but this was harder than it needed to be.  Thank you!

 

First, I added another 2GB stick of RAM along with the 1GB GeForce GT-430, but when I turned the PC back on, all I got was a musical song of beeps.  Not even the old fashioned error beep code, but musical notes!  2 long, 3 short, almost like a ring tone on a phone.  Wouldn't boot.

 

I removed and re-seated firmly both the graphics card and the RAM.  Sometimes that's the problem.    

 

Started searching on Google.  Tried each step separately, and got the extra RAM to boot without the video card, but not vice versa.  However, the video card worked fine in my own computer months ago...

 

Even went into the BIOS (F1 key), but on the Video Display tab I didn't want to mandate "PEG" (PCIe Graphics) from "Auto" (Detect), for fear it would lock me out of any display whatsoever (getting back into the BIOS).  Auto (detect) should work!  It should see the PCIe graphics card!  Why does it not?

 

Then, I found THIS page.  Even though this was a H515 series (not H520), the BIOS instructions are exactly the same.  Worked perfectly.  Smiley Happy

 

Disabling "Secure Boot" and enabling the "CSM" was the trick.  Booted up, with no musical beeps, and the VGA port on the GT-430 was recognized.

 

Then, I installed the latest 64-bit drivers for Windows 8.1 straight from nVidia website.  Viewsonic 1080p LCD monitor looks great on their computer.

 

To any other people who find this page, follow the steps in the post just above this one. Thank you!

 

 

elvis334
Paper Tape
Posts: 2
Registered: ‎02-07-2014
Location: USA
Views: 4,664
Message 7 of 9

Re: H520 with ATI Radeon Graphics card

I used the above BIOS setting/steps on my 515 to FIRST install the graphics card.

 

I did not have trouble when I installed memory at a LATER date:

 

I added an additional 8MB of Crucial Memory in the expansion slot.

After many mental trial runs and lots of hoping...

 

All I had to do was

power down - unhook all the cables

lay the comp on flat surface and remove two #2 Phillips Screws and the cover

TOUCH the metal CHASSIS of the comp to ground myself to it and discharge any static electricity

insert the memory with my other hand. Then slowy press it down with both thumbs being careful to only 

touch the plastic and wait for the click.

Visually inspect that it was in fact seated.

I reassembled the cover and the screws

Then try to remember where the cables went, which is easy with the Lenovo color labeling system

 

When I turned on the Comp it recognized the memory and life was goodMan LOL

 

I guess that (as I had already changed the BIOS settings) the comp looks for upgrades when you restart.

 

 

 

ChazzMatt
Paper Tape
Posts: 2
Registered: ‎05-23-2014
Location: Atlanta, GA
Views: 4,654
Message 8 of 9

Re: H520 with ATI Radeon Graphics card

Yes, installing the RAM is easy. You do not have to change the BIOS for that. I was able to install the extra memory before changing the BIOS.

It's the obscure stuff like disabling secure boot and the enabling CSM -- which is in a completely different BIOS section than "video display" and does not even seem to be related to installing new hardware -- which allows you to actually add a video card.

And that is not in the manual anywhere. Thanks to the people in this thread, I was able to do it.
michaelbarnaby
What's DOS?
Posts: 1
Registered: ‎12-10-2013
Location: SW Florida
Views: 4,426
Message 9 of 9

Re: H520 with ATI Radeon Graphics card

I want to add a big THANK YOU also - just got my H520 running with an ASus7700 graphics card. This card made me cry tears for over a month - worked fine, then went black. Sent to factory and returned. Nothing worked until I found this "recipe".

Thanks to all.
Mike

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors