cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ttetley
What's DOS?
Posts: 2
Registered: ‎01-28-2010
Location: Missouri, USA
Views: 2,286
Message 1 of 4

K230 missing driver after upgrade to Win 7

The upgrade to Windows 7 went very well, but there is one small problem.  There seems to be no device driver for "PCI Simple Communications Controller" which must have something to do with the multi-card reader since it has now gone missing.  I do not see anything on the drivers download page that seems to be for this hardware.  Where can I get this driver?

 

Thanks,

Tony

h2opoloplyr_11
Fanfold Paper
Posts: 22
Registered: ‎10-26-2009
Location: USA
Views: 2,214
Message 2 of 4

Re: K230 missing driver after upgrade to Win 7

I believe that's the intel management engine driver that fixes that exclamtion/question mark in the device manager. Go to consumersupport.lenovo.com and go to the drivers downloads page and I think it's all the way to the bottom.
ttetley
What's DOS?
Posts: 2
Registered: ‎01-28-2010
Location: Missouri, USA
Views: 2,177
Message 3 of 4

Re: K230 missing driver after upgrade to Win 7

Thank you for the reply, but I already tried that and it says that the bios option must be intalled for it to work.  I cannot find any bios option that even remotely sounds like anything related to the Intel management engine.

 

 

h2opoloplyr_11
Fanfold Paper
Posts: 22
Registered: ‎10-26-2009
Location: USA
Views: 2,118
Message 4 of 4

Re: K230 missing driver after upgrade to Win 7

Thats weird. But this is what i did and im running win7 with no question marks/exclamation points on the device manager.

 

Restored PC with the LVT button (red button on the keyboard during boot up at the lenovo screen.

 

Once everything is setup from factory, i went to consumersupport.lenovo.com

 

On option 1 i entered my serial number and hit go.

 

I downloaded  the BIOS update from the results. Make sure you read the instructions on which bios to get. There were 2 different updates. Make sure its the one for your machine.

 

Once thats done I went back to the consumer support webesite. And this time i went to option 2 and selected desktop, and the ideacentre k230 option.

 

Downloaded the:

 

Intel Chipset Driver for win7

ADI SoundMax Driver for vista

Intel Pro network driver (since thats the one i had show up on my device manager)

Common components installation

PCType

Intel Management Engine for win7 (55mb)

 

I restarted the computer with the win7 upgraded disc inside.

 

At the lenovo startup screen hit F12 (or whichever it says for boot setup)

 

Then choose CD.

 

When the setup screen shows up make sure you highlight the main hard drive and format first.

 

Then install win7 by following instructions.

 

Once everything is setup, install all the downloaded updates that i just listed, and hopefully by the time its all done, that you wouldnt have anymore problems with the device manager missing any drivers.

 

Check out current deals!


Shop current deals

Top Kudoed Authors