cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MichaelWeaser
Blue Screen Again
Posts: 2
Registered: ‎04-11-2017
Location: US
Views: 580
Message 1 of 3

Lenovo H430 slow hard drive problem with UEFI

I am having an issue with my Lenovo H430 desktop with the hard drive in it, The issue is that the hard drive is real slow in it when I have windows installed under Uefi mode,  but when the computer is in standard bios mode the computer works fine. The only thing that i know is that hard drives can have issues under UEFI which is caused by the hard drive not being aligned correctly, But i don't know how to check if the alignment is correct on the hard drive or not, and if the alignment isn't right , figuring what alignment is needed for the hard drive, and how to make sure it will format to that alignment. Also I think it could be alignment issue since if i try to benchmark it , it doesn't work, it says it can't finish certain tests like 4K test and other tests as well. I was also told to try to see if the computer has a bios update for it, but the bios update will not work on my model, I have tried installing it throughn DOS, windows 32 bit and even 64 bit, it says its not the right bios update for my model, and it shows up as a bios update for my model, unless the bios update only works for certain h430 models and mine isn't one of the models for that update. 

Support Specialist
Posts: 2,948
Registered: ‎02-22-2017
Location: GB
Views: 556
Message 2 of 3

Re: Lenovo H430 slow hard drive problem with UEFI

Hello MichealWeaser

Thanks for using the Lenovo forums.

Check the following post, it should of some help I believe.

 

Hope this helps, let us know how you get on.


==================================================================================
Did someone help you today? Thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!

 

This will help the rest of the Community with similar issues identify the verified solution and benefit from it.



Pesszimistának lenni a legjobb, vagy igazad van, vagy kellemesen meglepődsz...
MichaelWeaser
Blue Screen Again
Posts: 2
Registered: ‎04-11-2017
Location: US
Views: 544
Message 3 of 3

Re: Lenovo H430 slow hard drive problem with UEFI

I checked the alignment and its fine , I can't figure out why the hard drive is very slow in Uefi , but works fine in standard bios mode ,  I have tried 2 other hard drives it does the same thing . I am wondering if maybe there is a issue with the sata controller , or even the sata driver under Uefi or something like that , but i'm not totally sure.

Check out current deals!


Shop current deals

Top Kudoed Authors