Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo DesktopsLenovo Desktop Towers
All Forum Topics
Options

3 Posts

11-30-2013

UK

2 Signins

16 Page Views

  • Posts: 3
  • Registered: ‎11-30-2013
  • Location: UK
  • Views: 16
  • Message 1 of 3

Missing driver from IdeaCentre K540

2013-11-30, 19:35 PM

Hello,

 

Have done a new install of Windows 8.1 64 on this system, everything is working fine apart from one missing driver which as far as I can tell must be the card reader as that is not showing anywhere in device manager, and cards are not appearing in my computer when inserted, so I think this missing device is the card reader.

 

In device manager it shows as "PCI Simple Communications Controller".

 

The hardware ID of the device is:

 

PCI\VEN_8086&DEV_8C3A&SUBSYS_366D17AA&REV_04

 

A google search for this hardware ID results in nothing at all! There are 2 WIndows 8.1 64 drivers available for download in the support section for this computer, one is describes at "Bitland" the other is "Taisol", neither of them work.

 

Like I say I think this is the card reader but I'm not 100% sure, but if it's not the card reader not sure why that's not showing up.

 

Thanks.

Reply
Answer
Options

3 Posts

11-30-2013

UK

2 Signins

16 Page Views

  • Posts: 3
  • Registered: ‎11-30-2013
  • Location: UK
  • Views: 16

Re: Missing driver from IdeaCentre K540

2013-12-01, 13:08 PM

No it wasn't the chipset driver. Turns out it was the Intel ME driver. Not sure why a google search of that hardware ID results in nothing.. ?

Reply

Replies(2)
Options

1220 Posts

12-24-2010

Perth, Australia

259 Signins

21576 Page Views

  • Posts: 1220
  • Registered: ‎12-24-2010
  • Location: Perth, Australia
  • Views: 21576
  • Message 2 of 3

Re: Missing driver from IdeaCentre K540

2013-12-01, 7:19 AM

Hi PPC,

 

Welcome to the forum,

 

Try to install this driver: http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS037215

If it doesn't work try this patch: https://downloadcenter.intel.com/confirm.aspx?httpDown=http://downloadmirror.intel.com/20018/a08/infinst_autol.zip&lang=eng&Dwnldid=20018&keyword=%22series+6+chipset%22

 

Vince.

__________________________________________________________________________________

Knowledge is of two kinds. We know a subject ourselves, or we know where we can find information on it.


ThinkPad T510 4313-CTO Windows 8 x64 - Intel Core i7-620M - NVIDIA NVS 3100M - 8GB RAM - 240GB SSD- Intel Centrino Ultimate-N 6300 - Gobi 2000.
ThinkPad Helix 3697-CTO Windows 8.1 x64 - Intel Core i7-3667U - Intel HD Graphics 4000 - 8GB RAM- 256GB SSD - Intel Centrino Advanced-N 6205 - Ericsson C5621gw

Reply
Answer
Options

3 Posts

11-30-2013

UK

2 Signins

16 Page Views

  • Posts: 3
  • Registered: ‎11-30-2013
  • Location: UK
  • Views: 16
  • Message 3 of 3

Re: Missing driver from IdeaCentre K540

2013-12-01, 13:08 PM

No it wasn't the chipset driver. Turns out it was the Intel ME driver. Not sure why a google search of that hardware ID results in nothing.. ?

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms