Showing results for 
Search instead for 
Did you mean: 
What's DOS?
Posts: 1
Registered: ‎04-14-2015
Location: United States
Views: 323
Message 1 of 2

Software download

I have a Lenovo IdeaCentre Q190 Series

I tried to download TeamViewer but got the following error message 'Rollback framework could not be initialized, installation aborted'.  I have no idea what this means.  I also tried to download Plex Home Theater.  It appeared be complete but I could not find it any where on yhe computer including new apps and the download folder?

Social Support Agent
Social Support Agent
Posts: 5,824
Registered: ‎02-11-2012
Location: PH
Views: 319
Message 2 of 2

Re: Software download

hi there,


Your problem might be similar to this thread. Have you tried running the Teamviewer setup as administrator? 


As for the Plex Home Theater, have you tried downloading it again (i.e., with a different browser, download accelerator) ?Also, if you hit Run instead of saving the file, were you able to see the setup installation window? If these steps doesn't work, can you try to insert a USB flashdrive and try to save the Plex Home Theater installer there and observe.



Let me know how it goes.



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Check out current deals!

Shop current deals

Top Kudoed Authors