English Community

Virtual & Mixed RealityLenovo Explorer
All Forum Topics
Options

2 Posts

09-13-2019

GB

3 Signins

70 Page Views

  • Posts: 2
  • Registered: ‎09-13-2019
  • Location: GB
  • Views: 70
  • Message 1 of 3

Lenovo Explorer black screen

2019-09-13, 21:25 PM

Hello,

 

I just brought a Lenovo Explorer and i got all the drivers installed and ive checked that my pc can run WMR. When i launch the portal nothing appears in my headset and even when i launch steamVR with the WMR addon i still get nothing.

 

Ive tried everything, ive been at it for around 6 hours now and got nowhere.

Ive reinstalled windows 10 and im about to give up

 

Can anyone help me?

Reply
Options

445 Posts

11-04-2019

US

169 Signins

12767 Page Views

  • Posts: 445
  • Registered: ‎11-04-2019
  • Location: US
  • Views: 12767
  • Message 2 of 3

Re: Lenovo Explorer black screen

2019-11-27, 11:37 AM

 

Welcome to the Community Forums ! Glad to have you here.

 

Sorry for the delayed response, just joined here recently and noticed your post.

 

Please do the following steps for this to be sorted out:

 

  • Ensure that the USB connector of the Lenovo Explorer headset is connected to a USB 3.0 connector on your computer.
  • Disconnect the USB and HDMI connectors of the headset from your computer. Then reconnect the USB and HDMI connectors to your computer.
  • Restart your computer.

You can also try pressing Win+Y to switch between the computer desktop and Windows Mixed Reality Portal.

 

And you may also refer to this link to see what other users have done for this to be sorted out as well.

 

Update us on how it will go through. 

 

Thanks!

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

1 Posts

09-16-2020

US

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎09-16-2020
  • Location: US
  • Views: 5
  • Message 3 of 3

Re:Lenovo Explorer black screen

2020-09-16, 22:28 PM

I had the same problem.

Go into Device Manager -> Mixed Reality devices and get properties on Lenovo Mixed Reality.

Uncheck the box that says "Allow the computer to turn off this device to save power"

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete