Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo IdeaPad 1xx, 3xx, 5xx & 7xx, Edge, LaVie Z, Flex Notebooks Knowledge Base

Flex 10: Can't wake up from sleep after upgraded to Windows 8.1


I upgraded to Windows 8.1 but have an issue with waking the computer from sleep. 

When I tried to wake the computer, the screen will go black for quite some time and then it will reboot.


I have reinstalled the video driver but the problem still persist. 


If you are facing this issue, please check if you have covered the follwing steps before upgraded to Windows 8.1.


  1. Update all drivers and BIOS prior to updating to Windows 8.1
  2. All Windows updates are updated prior to updating to Windows 8.1

If you have not done any of the above, you are advised to revert back to Windows 8 and proceed with the neccesary updates.


If you need to restore the system to the point of your first boot up, just enter Recovery System (Push-button reset).


If you have attempted the above mentioned and problem still persist, it would be best for you to contact our service centre for assistance.


For a list of our service team within your vicinity, please click on the link below :


Servie Centres Contacts (By region)

Was this information helpful?

Yes No


el_beltagy On 2014-04-26, 20:09 PM

I have the same problem and i purchased the laptop during April 2014 and it originally come with Windows 8 32 bit version and i made all the available updates before upgrading to windows 8.1 as recommended by Lenovo and after update the system failed to wake up after sleeping and the only solution is to force the system to shutdown and I tried to find the last updated driver for vga card through Lenovo website but unfortunately the updates are available for 64 bit only (it is not clear why Lenovo used 32 bit system where it will continue support 64 bit system only) and when I called Lenovo customer support in UAE I got very amazing massage which is “we will support the preinstalled system only!!!!! As this is Microsoft problem and not Lenovo Problem and when I asked if this is true why there is no limitation alert showing with the laptop!!!! But actual I do not get any reply, in the end the Lenovo customer support recommendation as the following:

1-     You can search by yourself in the internet to find the updated driver as many other users!!!!

2-     You can wait till Microsoft fix windows 8.1 problems and using windows update to fix your problem!!!!

3-     You can rollback to windows 8 and if you face any problem we will support you!!!!!!

Really this is what happen with me !!!!!!!!!!!!!!!

susanalicebarry On 2014-07-21, 14:19 PM


I had the same problems, go into your search option and search either sleep or hibernate, it gives u the option of never sleep, worked for me but took 2 weeks of research to sort the problem out. Good luck :-)

Jasoonnmp On 2015-04-30, 17:46 PM

From what you're describing it sounds like more of a hardware issue, when your computer goes it sleep-mode it uses it's memory (ram) when it goes into hybernation it runs off the HDD. So if your computer doesn't wake up from sleep-mode then you most likely have a memory failure - if not that it can be your motherboard. I'd call customer support, and maybe have your unit sent it to have a closer look at it seeing as it's hard to verify the issue without it infront of me. - cheers 

chamin On 2015-06-04, 19:24 PM


Hi I have a similar problem.  Mine is the Flex 2-15 which came with windows 8.1.  I have to press the power switch for count of ~10 to power off and then reboot.  It's very annoying.

sharronheath On 2015-06-15, 13:39 PM

I have the same problem.  Won't wake from sleep mode.  Light is flashing and has beem for many days now.  Leaving town for a week.  When I return I hope the battery will be discharged, at which time I will change setting to never sleep. This Flex 2-15 also will not run bluetooth and the keyboard trackpad are glitchy.  The whole thing is a mess.   Bad choice. Never again.

rohitp On 2015-09-12, 15:01 PM

hi i might have a solution to your problems.

i also had same problems such as not being able to wake up from sleep mode, laptop does not completely shutdown and freezes when trying to restart.

These happened because the installation was corrupted.

Try to redo the whole installation again but this time when you-all click custom installation first format and then delete everything until you all get undisclosed space. 

First format because then partitions might be corrupted due to virus and you all can erase it then and there.

if u delete first it will only erase the data and not the virus.


when you all have done the above steps you can set the required  GB space for yourselves and proceed for installation. Once the installation is complete install the required drivers and then try restarting and shuting down your system this will fix all your issues and this worked for me.

abg~0001 On 2016-04-28, 13:01 PM

I have a 15 month old IdeaPad Flex 10. It worked OK first thing in the morning. I took a break and it looked as if it had gone to sleep - blue light ON. Nothing I can do wakens the machine.  I can see no way of rebooting to disable the sleep mode. When I press the On button, the light comes on and that s it. USB is not powered.


Any idea on what I do next? 

Majestic On 2016-10-14, 20:58 PM
pradeepbommi On 2016-10-31, 22:18 PM

try this if you are having issues with flashing light on the power button three times and sits idle:



Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop