English Community

Lenovo NotebooksLenovo IdeaPad 1xx, 3xx, 5xx & 7xx, Edge, LaVie Z, Flex Notebooks
All Forum Topics
Options

2 Posts

01-13-2021

US

3 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎01-13-2021
  • Location: US
  • Views: 10
  • Message 1 of 2

Flex 15IML - Randomly Switches between Laptop & Tablet Mode

2021-01-13, 21:35 PM

So 2 weeks after the 1-year anniversary of the purchase of my laptop (yes, right after the warranty expired), I noticed the screen would randomly change back and forth between landscape (laptop) and portrait (tablet) orientation. Frustrating, but I was able to stop the screen from doing this through the settings console. Now, I notice that the keyboard stops working once in a while, the virtual (touchscreen) keyboard is the only way to enter data. I conclude that my machine is still going into tablet mode on it's own. I couldn't care less if the tablet mode works or not. I thought it was cool when I was shopping for laptops, but now realize that I've NEVER used it for any purpose. 

 

QUESTIONS: 

Has anyone else experienced this? Is it a known issue with this model? 

How do I disable the tablet mode completely? There must be a bios setting to make the OS ignore the tablet trigger. 

What IS the tablet trigger? Is there a sensor in the hinge that tells the laptop the display & keyboard are folded back to back? Or is there an orientation sensor (like in a smart phone) that triggers the display orientation?  

 

I do (DID) love this laptop. It's light-weight and super fast, but this is driving me nuts! HELP! 

 

Dave Adams - resto1tb@gmail.com

 

Reply
Options

59 Posts

01-08-2021

PH

12 Signins

475 Page Views

  • Posts: 59
  • Registered: ‎01-08-2021
  • Location: PH
  • Views: 475
  • Message 2 of 2

Re:Flex 15IML - Randomly Switches between Laptop & Tablet Mode

2021-01-14, 19:45 PM

Hello @DaveAdams123,

 

Greetings.
 
There are two possible triggers responsible for this behavior, one is located at the hinge and other in the operating system. There appears to be no option in BIOS to permanently disable the trigger or sensors as well. 
 
You can try update the sensor driver on device manager and include the display driver as well, or check for drivers on our support site using the machine serial number.
 
In the meantime, the steps provided below should disable your tablet mode.
 
1. On desktop search bar, type 'tablet mode', and then press Enter.
2. Select Tablet mode.
3. You'll see, 'When I sign in', choose Use desktop mode.
4. There is the 'When this device automatically switches tablet mode on or off', select Don's ask me and don't switch.
 
I hope this helps your query.
 
Regards.​



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms