English Community

Lenovo NotebooksLenovo IdeaPad 1xx, 3xx, 5xx & 7xx, Edge, LaVie Z, Flex Notebooks
All Forum Topics
Options

5 Posts

08-03-2018

UA

17 Signins

174 Page Views

  • Posts: 5
  • Registered: ‎08-03-2018
  • Location: UA
  • Views: 174
  • Message 1 of 17

HDMI audio not working on Lenovo 530S-14ikb

2018-08-03, 7:22 AM

Hello

 

Yeasterday I have purchased a new  Lenovo 530S-14ikb and installed Windows 10 on it. All drivers was installed correctly and up to date but when I connect external monitor via HDMI the secod audio device are not show up (no sound from monitor speakers)

* I tried to change drivers to original from Lenovo support page of this laptop - not working

* I have installed latest Intel display audio drivers (and UHD 620) - not working

* I have changed HDMI cable - same result - not working

* I have tried to connect laptop to my TV - not working.

* I have turned off/on audio devices in device manager - not working

My old laptop is working fine with that TV and external monitor so the problem is with HDMI port itself of with it's drivers of 530S. Despite of all my efforts - the are not HDMI audio devices shown in a system (and no sound from speakers) .

 

Please help.

Solved! See the solution
Reply
Options

5 Posts

08-03-2018

UA

17 Signins

174 Page Views

  • Posts: 5
  • Registered: ‎08-03-2018
  • Location: UA
  • Views: 174
  • Message 2 of 17

Re: HDMI audio not working on Lenovo 530S-14ikb

2018-08-06, 9:18 AM

Update on Issue: By researching on this problem and test I have found out that the problem is in Intel Display Audio Driver. If I delete this particular driver - Windows automatically install stadard driver and in that case HDMI audio devices appears in playback devices but not working. I have tried several Intel drivers up to December 2017 but problem still persist. I think that it is an issue of latest versions of drivers. According to this thread https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/windows-10-hdmi-audio-not-working/293eec79-e0f8-4837-bbd0-341cfc9bd446 there are many people with same problem on different laptops.

 

Anyone who has correct sound on HDMI on Intel UHD 620 and core I5 8225u - please post your version of Inte display audio driver in here. The version could be found in Device Manager under section Audio devices. Thanks in advance.

Reply
Options

5 Posts

08-03-2018

UA

17 Signins

174 Page Views

  • Posts: 5
  • Registered: ‎08-03-2018
  • Location: UA
  • Views: 174
  • Message 3 of 17

Re: HDMI audio not working on Lenovo 530S-14ikb

2018-08-11, 18:25 PM

I have solved my problem. After long days of search and trying I have reinstalled Windows 10 and installed ALL chipset dirvers from this page https://pcsupport.lenovo.com/ua/ru/products/laptops-and-netbooks/500-series/530s-14ikb/downloads

The only difference between my first install is that I have installed Intel Mamagement Firmware and after reboot HDMI audio appeared immediately! The problem was in that firmware. It is the only thing that I have not tried.  I hope it will be helpfull to someone.

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

08-22-2018

DE

14 Signins

120 Page Views

  • Posts: 3
  • Registered: ‎08-22-2018
  • Location: DE
  • Views: 120
  • Message 4 of 17

Re: HDMI audio not working on Lenovo 530S-14ikb

2018-08-22, 14:56 PM

Hello,

 

I have the same problem as you. I have reinstalled Windows many times and always installed all drivers from the website (including the Intel Management Firmware), but there is now sound.

Did you do anything else than only installing all these drivers? And is "HDMI Audio" now always displayed in the Sound-Options (also when it is not plugged in)?

It has to be a problem with these drivers for Windows because it works on a Linux Live-USB.

 

Please help me, I really don't know how to fix it. Thank you in advance.

Reply
Options

2 Posts

12-02-2018

RO

3 Signins

32 Page Views

  • Posts: 2
  • Registered: ‎12-02-2018
  • Location: RO
  • Views: 32
  • Message 5 of 17

Re: HDMI audio not working on Lenovo 530S-14ikb

2018-12-02, 10:07 AM

Hi,

Same problem here.

I installed all the drivers (including Intel Management Firmware), but nothing changed.

The HDMI audio does'nt show up in the Sound -Playback devices.

The same TV and HDMI cable are working very fine on another laptop (Legion Y530).

 

 

Catalin

Reply
Options

2 Posts

12-02-2018

RO

3 Signins

32 Page Views

  • Posts: 2
  • Registered: ‎12-02-2018
  • Location: RO
  • Views: 32
  • Message 6 of 17

Re: HDMI audio not working on Lenovo 530S-14ikb

2018-12-08, 17:27 PM

Finally I solved the issue after many wasted nights trying absolutely everything.
I reinstalled Windows 10 from scratch, put all the drivers from Lenovo (wifi not conected), less the 11.8 update for Intel Management Engine Firmware. It seems this update is the problem.

Catalin

Reply
Options

2 Posts

12-11-2018

RO

2 Signins

13 Page Views

  • Posts: 2
  • Registered: ‎12-11-2018
  • Location: RO
  • Views: 13
  • Message 7 of 17

Re: HDMI audio not working on Lenovo 530S-14ikb

2018-12-11, 9:48 AM

Well that's just stupid... :( 

I will try this, hopefully it will work. Any particular version of Windows 10 that you installed?

Reply
Options

3 Posts

12-27-2018

RO

1 Signins

54 Page Views

  • Posts: 3
  • Registered: ‎12-27-2018
  • Location: RO
  • Views: 54
  • Message 8 of 17

Re: HDMI audio not working on Lenovo 530S-14ikb

2018-12-27, 23:12 PM

After 2 months of having the same issue I have found the problem. 

It is the bloody UEFI mode vs. Legacy in the BIOS

Converting to UEFI does not mean you need to reinstall Windows !

 

Just follow this tutorial:

https://technet.microsoft.com/en-us/windows/mt782786.aspx

 

Basically you need to do the following (Less than 5 minutes):

 

1. Run cmd.exe as administrator

2. Go to C:/windows/system32

3. Run mbr2gpt.exe /validate

3.1 If you encounter en error that it can only be used from the Windows Preinstallation Environment you will need to use the override command

3.2 run mbr2gpt.exe /convert /allowFullOS if 3.1 applies, else just run mbr2gpt.exe /convert

4. After succesfull step 3.2 restart laptop and enter BIOS (FN + F2)

5. Go and modify the BOOT Mode from Legacy to UEFI

6. There you go, HDMI sound is on and your TV will appear in the sound playback list when you connect it.

Reply
Options

1 Posts

03-13-2019

ES

2 Signins

30 Page Views

  • Posts: 1
  • Registered: ‎03-13-2019
  • Location: ES
  • Views: 30
  • Message 9 of 17

Re: HDMI audio not working on Lenovo 530S-14ikb

2019-03-13, 19:34 PM

For ideapad 330 same problem.

 

FIXED:

 

1. download last UHD 630 graphics "25.20.100.6577", don't try to install it, it will show error.

 

2. Extract content with Universal Extractor.

 

3.  Enter in Device Administrator and Uninstall  UHD Graphics 630 manualy.

 

4. Now, look for changes on devices. It will show you again UHD Graphics 630.

 

5. Update driver manualy and set it to look for in folder where last UHD Graphics where extracted before.

 

6. Restart.

 

7. Try your HDMI Audio.   FOR ME IT WORKED!

 

 

 

 

Reply
Options

2 Posts

06-29-2019

RO

1 Signins

22 Page Views

  • Posts: 2
  • Registered: ‎06-29-2019
  • Location: RO
  • Views: 22
  • Message 10 of 17

Re: HDMI audio not working on Lenovo 530S-14ikb

2019-06-29, 18:28 PM

Hello, i have the same problem. I tried everthing but without success. 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete