Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit our eSupport here.

English Community

Lenovo NotebooksLenovo IdeaPad 1xx, 3xx, 5xx & 7xx, Edge, LaVie Z, Flex Notebooks
All Forum Topics
Options

2 Posts

02-18-2021

United States of America

2 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎02-18-2021
  • Location: United States of America
  • Views: 10
  • Message 1 of 4

Ideapad 530S-151KB wifi issues, help!

2021-02-18, 6:05 AM

Serial# *******

Product # 81EV000HUS

Bios version 7PCN44WW

 

Hello there,

 

Not too long ago I purchased this ideapad 530S for school and after around a year of use the battery died, so I purchased a replacement. Not long after that though, the wifi started to cut out and overall the device was very slow. At first I thought it was my internet but after confirming that everything was good on that end I decided to replace the wifi chip with a 01AX769 - Lenovo WLAN 11ac 2x2 INT 9260NGW chip. After uninstalling the drivers and rebooting I still had really bad wifi throughput (we are talking 0-10 Kbps). I have even installed an older driver (2017) with no luck. At this point I'm a little disappointed since my $700 2 year old laptop is a big fat paper weight. If you have any suggestions then I would greatly appreciate it ( I have already cleared all my caches, deleted old files, and all other junk on my laptop for reference)! 

 

Admin note: serial number edited to prevent potential abuse

Reply
Options

1847 Posts

03-11-2020

Greece

204 Signins

9556 Page Views

  • Posts: 1847
  • Registered: ‎03-11-2020
  • Location: Greece
  • Views: 9556
  • Message 2 of 4

Re:Ideapad 530S-151KB wifi issues, help!

2021-02-18, 9:59 AM

Hi Violenteddybear,

 

Welcome to the Community Forums.

 

Here's some troubleshooting steps you can perform to try and remedy the issue:

 

Step 1: Network Reset.
- Right click the Windows icon in the bottom right and select "Settings"(cogwheel) or search for it.
- Select the "Network & Internet" Icon.
- While in the "Status" tab, scroll down until you find "Network Reset"
- Click this and continue, then perform a computer restart.
- Find your network and connect to it (You will have to type in the password (SSID/Key) again to connect)
- Make sure you tick the box that says "Automatically connect to this device" or similar

 

Step 2: Disable Automatic Hardware drivers update.
- Right click the Windows Icon, select the "Search" Function.
- Type "Control Panel" and select "Small icons" or "Large Icons" in the "View By" top right.
- Click the "System Icon"
- Navigate to "Advanced System Settings" -> "Hardware"
- Click "Device Installation Settings" and Select "No"
** This will prevent Windows from interfering with the drivers of your WLAN and device in future Windows updates.
 
Step 3: Uninstalling Wifi Device + Drivers.
- Right click the Windows icon in the bottom right and select "Device Manager"
- Navigate to the "Networks Adapter" tab and drop it down.
- Right click the "Wireless Network Adapter / WLAN device" and select "Uninstall Device"
- Tick the box "Delete the driver software for this device" if prompted.
- Perform a restart of the computer, then run/install the OEM network drivers provided on the Support Page
- Located under Drivers & Software, Manual Update then Network Wireless: LAN.
- Right click the file and select "Run As Administrator"

 

Step 4. Checking Bandwidth frequency
Some wireless network cards allow you to limit the channel width via the Advanced properties in Device Manager, so you might try limiting it to 20-40MHz as a test

- Right-click Start and select Device Manager
- Left-click to expand the Network Adapters section
- Right-click on your Wireless Adapter and select Properties
- Select the Advanced Tab and look for a Channel Width setting with the ability to change between 20 / 20-40 / 20-40-80 mhz. 

- Normally 20Mhz for the 2.4Ghz Frequency or 40Mhz or more for the 5Ghz Frequency. Lower then this will affect data rate significantly.


Step 5. Checking Band Frequency
** These settings may differ between WLAN adaptors.  
Try to go to Device Manager again, and right click your WLAN device. Select properties and then "Advanced"
Try forcing the WLAN device to use the 2.4ghz band and turn off the "Auto" for the other band frequency.
If this seems to drop the connection more, then try using the 5Ghz band.
- Depending if the device is far or close to the router, or if there is walls or floors between the device and router, check general frequency band info below.

 

Step 6. What Network protocol is the Network Interface Card(NIC) using ? Example: 802.11a /b /g /n /ac or /ax?

 

 

 

Here's some General Wifi Info:

Frequency = What network frequency they're able to use. Wifi has two standards, 2.4ghz and 5ghz, but we also have 6ghz and 60Ghz Frequency bands.

2.4GHz (slower, but longer range) , the 2.4ghz band is also a very crowded bandwidth, used by everything from garage openers to microwaves and lots of other stuff.
5GHz (faster, but shorter range). is less crowded, depending on where you live, but because of the higher frequency is not able to penetrate walls as easy as the 2.4ghz.

 

Bandwidth = The channel bandwidth of a wireless signal determines that signal's data rate. The higher the channel bandwidth, the faster the connection.  Normally you'd use the 20mhz range in the 2.4ghz network frequency and 40mhz or more in the 5ghz network frequency.

 

IEEE 802.11 = They are part of the IEEE 802 set of local area network (LAN) protocols, and are the world's most widely used wireless computer networking standards, used in most home and office networks to allow laptops, printers, smartphones, and other devices to communicate with each other and access the Internet without connecting wires. 

 

Stream Data rate = How much mbit/s you might be (It's an aprox up to calculation) able to see on the Network protocol, determined by the bandwidth used and by the IEEE Network Protocols(802.11xx etc). (ex: 3466 Mbit/s = 433.25 MB/s)

 

Range = Well, just that, range, determined by the Network Frequency it's on (2.4ghz or 5ghz).

 

 

Hope this helps

 

Regards

 

Voithos



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Private Message; questions belong in the forums.

Reply
Options

2 Posts

02-18-2021

United States of America

2 Signins

10 Page Views

  • Posts: 2
  • Registered: ‎02-18-2021
  • Location: United States of America
  • Views: 10
  • Message 3 of 4

Re:Ideapad 530S-151KB wifi issues, help!

2021-02-18, 23:14 PM

Hello there,

 

Thank you for the explainations and the well thought out response. I was able to do everything leading up to #6. The manual update seemed to go well but it isn't allowing me to keep the changes made to the frequency of the WLAN (chose "channel width for 2.4 GHz" with an option of 20 Mhz only and "channel width for 5 GHz" with an option of 20 Mhz only). Every time I applied the changes and checked, it was stuck on "802.11a/b/g Wireless mode" for property with a value of "5Ghz 801.11a."

 

Not sure if this helps but when I pull up task manager then click on performance, I noticed my CPU hitting 100% when opening multiple windows (when I say multiple, I'm talking about only 4 windows) in google chrome. Additionally the wifi speed was ranging from 20- 300 Kbps.

 

Reply
Options

1847 Posts

03-11-2020

Greece

204 Signins

9556 Page Views

  • Posts: 1847
  • Registered: ‎03-11-2020
  • Location: Greece
  • Views: 9556
  • Message 4 of 4

Re:Ideapad 530S-151KB wifi issues, help!

2021-02-19, 11:25 AM

So you are not able to force it to either 2.4ghz or 5ghz ? Can you disable one of the frequencies at all ?

 

802.11a is one of the older protocols, but still should be able to give up to 54Mbps on the 5Ghz Frequency.

 

Also, for the 100% CPU issue, try seeing if a Clean Boot solves that:

 

Clean Boot: 
- On the search bar, type msconfig and hit Enter. 
- Check the check box Hide all Microsoft services, click on Disable all and click OK. 
- Under Startup tab, click on open Task Manager. 
- Under startup tab in Task Manager, select the startup items and click Disable. 
- Close Task Manager, under Startup tab of System Configuration, click OK. 
- Restart PC.

 

If the CPU usage is less after this, then it would indicate that there are some background programs running that is limiting performance.

 

Regards

 

Voithos



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Private Message; questions belong in the forums.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms