English Community

Lenovo NotebooksLenovo IdeaPad 1xx, 3xx, 5xx & 7xx, Edge, LaVie Z, Flex Notebooks
All Forum Topics
Options

1 Posts

09-24-2020

AF

2 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎09-24-2020
  • Location: AF
  • Views: 10
  • Message 1 of 2

Lenovo IdeaPad Flex 14 Camera Not Working

2020-09-24, 9:04 AM

NOTE: I'm new here, so this might be long; additionally, I have no idea how to make the images smaller (in case they look big on your screen). So I'm sorry in advance. But I hope someone can help.

 

I bought this computer, a Lenovo IdeaPad Flex 14, last week for college and it arrived on the 17th of September. Today, September 23 (at time of writing), I found out that my camera is not working. It worked before, when I was testing out the built-in camera and on Zoom. According to Settings>Privacy>Camera>List of apps that can access my camera, the last time I accessed the built-in camera on the Camera app was the day it came, on the 17th. I also experimented with the Zoom camera that day, and I believe that the camera continued to function through Zoom for some days after. I haven't tried accessing the built-in camera through any application, be it the Camera app or Zoom, for the last few days until today, which is when I found out about the issue.

 

The only reason I can think of as to why my camera would be having issues is that one point in time (between when I wasn't experimenting with the camera anymore and today) when I accessed Lenovo Vantage to turn off my camera as an extra measure to protect my privacy against any possible breach or invasion. Since I wasn't going to be using the camera until online orientation began (which, for me, as a UCD freshman, begins tomorrow...), I didn't notice anything out of the ordinary the following days. Today, when I decided to give my Zoom tech settings a final check-up, I found out my camera wasn't working when it told me that no camera could be detected. I went over my Windows settings and strangely, everything was fine. So I launched the Camera app and this is what I see: 

 

So I went over the McAfee settings (free trial that came with this laptop) and turned off the firewall as recommended by someone on the internet. That didn't work. Then I uninstalled the SurfEasy VPN that also came with the laptop. That didn't work either. The following is a list of things I have tried (not in chronological order, as my brain has been chaotic since this issue was discovered) per recommendation from online forums and articles (and that have also failed to work).

 

Keep in mind that I'm a fresh 18 YO with absolutely no technical or professional knowledge or background whatsoever who could only rely on the wisdom of the internet.

 

  • F8/FN+F8
  • Restarting.
  • Shutting down.
  • My privacy shutter over the camera is obviously not the problem, but I tried anyway. Haha....didn't work.
  • Resetting (while keeping my files) via Windows>Settings>Update & Security>Recovery>Advanced Startup>Restart Now>Troubleshoot>Hardware something. Didn't work.
  • All my updates have been installed. Hardware scans (from Lenovo Vantage) and PC as well as software scans haven't found anything wrong. My computer is supposedly in good health.
  • Windows troubleshooter keeps telling me that I should restart my computer to fix any problem, which I do, but it doesn't work.
  • Windows>Settings>Camera. I couldn't find a fix here, since camera access has always been on and my Microsoft store apps and desktop apps listed further down the page can access the camera.

 

  • For this Lenovo Vantage section, see Files 1>2>3 in order at the end of the post.
  • Via Lenovo Vantage. I went to Lenovo Vantage>Device>My Device Settings>Display & Camera, and the camera panel that used to be there on the page is missing. Completely gone. Zero. Zitto. Nothing. Nada. Just the display panel and its "Eye Care Mode" all by itself.
  • Lenovo Vantage again. I'd seen on the internet that people recommend to go to Lenovo Vantage>Hardware Settings>Audio/Visual for this kind of problem, but hardware settings is nowhere to be found!!! I can't find it! At all! It's just. Not. There!!!
  • Lenovo Vantage again! I opened the little Lenovo Vantage pop-up widget from the taskbar and there was no camera button to toggle on/off! I searched for it within the app, but as you know, only the display panel was on the pertaining page. However, after another action I took (I'm not sure if it was after I reinstalled Lenovo Vantage+Service, see next bullet point below, or after I reset the laptop via Advanced Startup Restart), when I clicked the widget again from the taskbar, the camera toggle button was there. But it was grayed out; at some points, when I hovered over it, my cursor changed to the red no symbol; mostly, though, I was able to click it. However, even when I did click it, it would take me to the Lenovo Vantage Display & Camera page, where only the display panel was visible and accessible. I took a video of this (SEE END OF POST). About two minutes after I took the video, however, the camera toggle button from the taskbar widget completely disappeared! Right before my eyes! There it was, then glitch, poof, and gone...

 

  • Per a post by Lenovo Employee wangyanyan on another user's thread: (1) Uninstalling Lenovo Vantage and Lenovo Vantage service from Windows>Settings>Apps. (2) Opening Device Manager>System Devices>"System Interface Foundation V2 Device", checking "Delete the driver software for this device" on the pop-up window, and uninstalling the V2 device. (3) Reinstalling Lenovo Vantage (+Service) via the Windows Store and launching it. After I followed these steps, I checked the Camera app again and saw the same screen as in the image above. I then opened Lenovo Vantage>Device>My Device Settings>Display & Camera, and the camera panel is still missing.
  • I went to Device Manager, but I couldn't find Camera or Imaging Devices anywhere, not even when I tried to Action>"Scan for hardware changes", Action>"Add legacy software" (see bullet point below), or View>"Show hidden devices." I think before the reset in the fourth bullet point, though, I probably saw Imaging devices (???) after clicking show hidden devices. I can't remember clearly anymore, though, and it's not showing up anymore soooooo.
  • Installing my device-model-specific (via serial number on the official Lenovo page through my account) camera driver. I opened the download and I have no idea what happened from there. Like, a screen just popped up and then disappeared all within a split second and nothing happened. I tried to see if it had been installed through Device Manager's Action>"Add legacy software," but either I'm too stupid/unknowledgeable or it was just foreign land to me, since I had no idea what to do from there from the way-too-technical pop-up window I got. Action>"Scan for hardware changes" brought no results, either.

 

  • I saw online about some BIOS what-the-heck or whatever it was, but I followed the instructions and entered the BIOS system thingy but didn't know what to do from there so I just exited.
  • The Lenovo Virtual Support Assistant could not help.
  • I went to my files for the driver folder as part of another recommended fix. But there were two, one labeled DRIVER and another labeled Drivers. I went through both and clicked random files but obviously there were no results and I had no idea what else to do with this step.

 

 

Lenovo Vantage File 1. 11:06 PM, camera toggle is visible in the LV taskbar widget.

Lenovo Vantage File 2. Video evidence I uploaded. Shows how the camera toggle button doesn't work and leads me instead to the pertaining LV app page, where only the display panel is to be seen.

Lenovo Vantage File 3. 11:09 PM. The camera toggle has disappeared.

 

If you made it to the end, thank you. I sent in a support request to the Lenovo team, but I don't know when they will reply. I have no idea what to do and orientation is tomorrow, so I hope some knowledge and awesome person can help or at least offer some advice or possible fixes. Thank you T.T

Reply
Options

989 Posts

03-11-2020

NO

120 Signins

5531 Page Views

  • Posts: 989
  • Registered: ‎03-11-2020
  • Location: NO
  • Views: 5531
  • Message 2 of 2

Re:Lenovo IdeaPad Flex 14 Camera Not Working

2020-09-24, 9:29 AM

Hello JoJo2442,

 

Welcome to the Community Forums.

 

Firstly I need to commend you on a job well done when it comes to the troubleshooting you did.

Secondly. Seeing as you have gone through pretty much all known troubleshooting regarding this issue, I can rightfully say it's difficult to figure out where things have gone wrong here. Especially after system resets.

 

What I'd like for you to try though, is to do a factory reset of the device, as I do believe this is very different from the Windows recovery reset and slightly different from the Advanced Startup Recovery setup.

 

Here's how: 

 

OKR - One Key Recovery

**This is a complete factory reset of the computer

**Loss of data can occur, so we advise you to backup your data if possible.

 

- Completely shut down the device.  

- Press the Novo Button : Page : 12 - It is the small reset hole on most devices that you need a unfolded paperclip to reach.  

 

- When the system boots up, a menu will appear, select System recovery and follow the recovery process.

- When entering the Windows environment again. 

- Important: Perform the step below before allowing any Windows updates.

 

Disable Automatic Hardware drivers update

- Right click the Windows Icon, select the "Search" Function.

- Type "Control Panel" and select "Small icons" or "Large Icons" in the "View By" top right.

- Click the "System Icon"

- Navigate to "Advanced System Settings" -> "Hardware"

- Click "Device Installation Settings" and Select "No"

**This will prevent Windows from interfering with your hardware drivers in future updates, but keep crucial security updates rolling.

 

In the event this does not work. I'd conclude that something has gone wrong with the device, hardware wise, and I'd suggest contacting support as you have and see what can be done to fix/repair/replace it.

 

Regards

 

Voithos

 

 

 

 



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Personal Message; questions belong in the forums.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete