English Community

Lenovo NotebooksLenovo IdeaPad 1xx, 3xx, 5xx & 7xx, Edge, LaVie Z, Flex Notebooks
All Forum Topics
Options

6 Posts

06-01-2020

US

4 Signins

20 Page Views

  • Posts: 6
  • Registered: ‎06-01-2020
  • Location: US
  • Views: 20
  • Message 1 of 3

USB-C Port not providing power to devices.

2020-06-01, 22:05 PM

The USB-C port on my new Ideapad 5 15IIL05 does not provide power to any USB-C devices connected to it.  If you plug anything into it, the laptop doesn't even detect that anything has been plugged in.  However, if you plug in a USB-C multiport adapter that has an external power supply, the laptop is able to see the multiport adapter and use the devices attached via it.  I've already used Lenovo Vantage to install all of the latest driver and BIOS updates.  Nothing seems to be bringing the port to life.

Reply
Options

1020 Posts

03-11-2020

NO

123 Signins

5676 Page Views

  • Posts: 1020
  • Registered: ‎03-11-2020
  • Location: NO
  • Views: 5676
  • Message 2 of 3

Re:USB-C Port not providing power to devices.

2020-06-02, 8:54 AM

@ tonetl wrote:
 

 

The USB-C port on my new Ideapad 5 15IIL05 does not provide power to any USB-C devices connected to it.  If you plug anything into it, the laptop doesn't even detect that anything has been plugged in.  However, if you plug in a USB-C multiport adapter that has an external power supply, the laptop is able to see the multiport adapter and use the devices attached via it.  I've already used Lenovo Vantage to install all of the latest driver and BIOS updates.  Nothing seems to be bringing the port to life.

 

 

Hi there Tonetl.

 

 

Welcome to the Community Forums.

 

 

Have you tried updating the Chipset / Serial IO and Management Engine Interface(MEI) drivers for your device ?

From what I can see, they are fairly new, as of 2nd of February, they might be able to assist in bringing the USB-C device back.

 

Head over to https://pcsupport.lenovo.com/

 

Just plot in your in your serial number and hit enter, might have to hit it twice. Then head to "Drivers & Software" -  "Chipset" 

Download and install  Chipset/Serial IO/Mei drivers.

**Note: Make sure you have your AC adapter connected and at least 80% battery charge when performing these updates.

Right click the files and select "Run as Administrator".

 

 

Hopefully these will help with the issue. Let us know how it works out.

 

 

Have a nice day!

 

 

Voithos

 



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Personal Message; questions belong in the forums.

Reply
Options

1 Posts

10-17-2020

US

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎10-17-2020
  • Location: US
  • Views: 0
  • Message 3 of 3

Re:USB-C Port not providing power to devices.

2020-10-17, 16:44 PM

I have the same problem and did as you suggested but had no effect. the failure appeared to have happened when the computer shut down in the conserve battery mode and when restarted the USB-C had no power. I verified that the hub works when connected to another computer. Hope this helps in finding a real solution to the problem.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete