English Community

Lenovo NotebooksLenovo IdeaPad 1xx, 3xx, 5xx & 7xx, Edge, LaVie Z, Flex Notebooks
All Forum Topics
Options

2 Posts

06-05-2020

DE

7 Signins

95 Page Views

  • Posts: 2
  • Registered: ‎06-05-2020
  • Location: DE
  • Views: 95
  • Message 1 of 3

Unbricking Ideapad 5 15ARE05?

2020-06-05, 16:47 PM

TL;DR: after playing with Windows and Linux / Ubuntu installs with different setups, I can't boot anything anymore, as everything results in "0xc0000034 - Your PC needs to be repaired. An unexpected error has occurred. Error code: 0x0000034" and the only option presented is ESC to enter UEFI. Always. Except for some hangs, way before anything OS related I assume.

 

------

 

Two days ago I got this new notebook. Initial install was just FreeDOS. I eventually installed Ubuntu 20.04 via netimage / mini.iso on it  (after struggling with broken Debian SID installer, non-working Ubuntu 20.04 server installer and crashing normal Ubuntu installer), but left a few GB to try Windows later, eventually to debug Linux HW problems, like the non-working touchpad mentioned in some forum thread in the internet. I deleted all the partitions, just added a new EFI one, a 2nd one for the LUKS Ubuntu setup and left some free space for my later planned Windows endeavors. As expected, the touchpad didn't work, even with the latest available mainline kernel (5.7) from Ubuntu.

 

I decided to install a Windows Pro to check out the driver status and have a look, if I can somehow identify the touchpad and eventually write a fix (optimistically). Turned out more complicated then expected to create a bootable media, but in the end I had an install (incl. BitLocker FWIW). But it had horrendous shutdown times at some point (5-10 min), eventually from installing Lenovo Vantage, and some other problem with my tried setup, so I decided to reinstall it, as I expected to eventually boot it a few more times (manually stopping the Lenovo Vantage service before shutdown crashed it, but sometimes resulted in a fast shutdown…).

 

So I booted my Windows USB media to delete the Windows partitions (there was now also a recovery partition, which I could delete), but the installer didn't want to allow me to delete the main Windows partition (BitLocker?) for whatever reason. So I thought to boot into Linux to get rid if it - not really anything else left at this point. That wasn't a good idea, because now I can't boot anything anymore; literally.

 

When starting the notebook I instantly get an error message after the Lenovo splash (from the Windows Boot Manager, would be my guess): "0xc0000034 - Your PC needs to be repaired. An unexpected error has occurred. Error code: 0x0000034". The only option presented is ESC to enter UEFI.

 

That UEFI now lists just the following entries:

 

  1. "Windows Boot Manager"
  2. ubuntu
  3. NVMe: ...

 

where it previously had quite a few more options in the boot list (don't know what, but the list was much longer).

 

If I have USB media attached, either the used Windows or Linux USB install one or both, they show up in addition in that list.

 

I can change the boot priority, save and exit, and … am always presented with the same Windows error message. Re-entering UEFI shows "Windows Boot Manager" on the top again, which kind of explains the result.

 

Now there is also the F12 boot menu, which is kind of hard to reach, as the Laptop boots too fast (but you get a very loud beep, if you would reach the menu normally on that laptop, compared to normal volume on my old Thinkpad, but I digress here). This now just hangs in the Lenovo splash screen.

 

So I tried the Novo button hole. That works like a power button and will present four options. All of them also result in the same "0xc0000034" error message or just a hang.

 

In the BIOS I basically tried everything that could remotely produce a difference. I've tried to use Legacy boot, load the default optimized and non-optimized settings reset the TPM / secure boot. The result feels like "Groundhog Day" after a few tries.

 

Since I don't have matching screw drivers, I wasn't able to test, if removing the NVMe or formatting it would help. My Thinkpad P51 is supposed to have a 2nd free M2 slot and "normal" screws, so I probably could do that at some point.

 

I'm a bit frustrated now, after the long delivery time, and sending it to repair would probably add an other month, if the shipping time is an indicator for the repair time :-(

 

So if you made it to this point, I just want to ask, if you can imagine anything I might still be able to try to fix this problem?

 

Reply
Options

2 Posts

06-05-2020

DE

7 Signins

95 Page Views

  • Posts: 2
  • Registered: ‎06-05-2020
  • Location: DE
  • Views: 95
  • Message 2 of 3

Re:Unbricking Ideapad 5 15ARE05?

2020-06-06, 15:24 PM

Two hours ago, I was able to unbrick the notebook even without opening the case.

 

I found - I think - an additional bug in Lenovos implementation of the UEFI for that notebook, which I essentially exploited.

Not that I could know the result at this point, but anything able to affect the menu in a permanent way at this point was worth a shot.

 

I already knew that additional boot media items still showed up in the UEFI setup, if they were connected at the start. Just the boot order was not changeable.

I wondered, what would happen, if I removed that media while inside the UEFI. Turns out, that preserved the entry permanently! So here I began hacking the boot menu entries. A few observations:

 

  1. Entries become permanent, if the device is removed while in the UEFI setup and then saved an exited.
  2. If you now boot again with the USB media attached, and enter UEFI, it mangles the device name by concatenating it to the previous entry.
  3. This works with any media in any port and would result in mangled names from multiple devices together for the same port.
  4. Attaching an RJ45 USB adapter with an integrated USB hub results in two additional, permanent network boot entries (IPv4 + IPv6).
  5. Attaching my boot media to the USB hub, got me two new and even longer mangled entries.

 

At this point I tried again to change the boot order to "ubuntu", and this time it worked!

 

I booted into my Linux, and got rid of all the crap in the EFI boot manager using efibootmgr.

But now the changing of the boot order in the UEFI is broken again :-(

The F12 boot menu still just hangs and the same for the novo button boot menu entry.

 

Linux's efibootmgr still shows disabled entries for:

  • Boot Menu
  • Setup
  • Diagnostic Splash
  • UEFI Diagnostics

 

If someone can post an efibootmgr from a working system, that would be great for reference.

 

Meanwhile I also re-added the permanent entry for the Windows USB install media, changed the boot order in Linux and was able to remove the old Windows partition and re-install it.

I currently use either Windows recovery boot or the Linux boot manager to enter UEFI or switch the next boot device, because the boot menu still doesn't work.

 

While I wouldn't call the current state fixed, as boot menu and order aren't working, for me it's currently usable again.

But since the notebook is not meant for me, but for someone not technically savy, I won't give them the machine right now.

 

I'm pondered about resetting the whole EFI partition, but am currently to **bleep**htened, this would result in a broken system again.

Reply
Options

1 Posts

08-17-2020

IT

1 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎08-17-2020
  • Location: IT
  • Views: 0
  • Message 3 of 3

Re:Unbricking Ideapad 5 15ARE05?

2020-08-17, 19:30 PM

hi jmux,

I encountered the same problem with my 15ARE05: the order of boot entries isn't saved and the description is chained over and over (in my case not only the description of my usb drive but also the one of my nvme drive).

I also bought the computer with FreeDOS (may this have a part in the issue?) and I also installed both Linux (Manjaro in my case) and Win 10.

My disk layout is different: I installed Manjaro on the nvme drive and Win 10 on the 2.5'' drive.

 

Did you find anything else after your last post? This looks an horrible bug to me, but I can't find any other reference to it.

In my opinion the dual boot thing has something to do with the bug, or perhaps the simple fact that we installed Linux (that might have messed up with efivars)? I don't know.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete