cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Daisuke
Paper Tape
Posts: 2
Registered: ‎08-09-2016
Location: US
Views: 966
Message 1 of 4

100 15iBD - blank screen after lenovo logo

Well, as the topic suggests, my laptop has a blank screen after the lenovo logo when I power it on. The only thing that shows up is a blinking underscore. Please help.

 

Mod's Edit: System model added to the front of Subject line to improve visibility / clarity.

 

Sr Support Specialist
Posts: 7,440
Registered: ‎11-30-2015
Location: PH
Views: 935
Message 2 of 4

Re: 100 15iBD - blank screen after lenovo logo

Hi Daisuke , 

 

Welcome to the Community Forums. 

 

Would you have the machine number ? Check on the machine number from the sticker or check it from here ,just keep your serial number confidential.

 

Best way to proceed is to isolate the issue . You can shutdown the PC and unplug the ac adapter , remove the battery (if removable) and press and hold down the power button for 12 seconds to drain remaining power . 

Use the Novo button instead to turn on where you expect to see the Novo Menu . Choose BIOS set up and verify if the harddrive is detected . You can F9 to reload defaults and F10 to save and exit. 

 

If the BIOS screen and tabs are working then we are safe to conclude that on the machine level , the laptop is working so that would now lead us to Boot issue either bad windows start up or bad display driver. 

 

Try to connect it to any available external monitor  ( press any FN keys to toggle if needed ex. FN + F10 ).

Any display on the external?  How is pressing ctrl alt del , any changes ? Tap on caps/ num lock ,see if any indicator led going on off too. 

 

Update us how it goes. 

 

Regards

 

Mod's Edit: System model added to the front of Subject line to improve visibility / clarity.

 



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Daisuke
Paper Tape
Posts: 2
Registered: ‎08-09-2016
Location: US
Views: 903
Message 3 of 4

Re: 100 15iBD - blank screen after lenovo logo

I tried what you suggested, but any time I push the novo button the only thing that happens is the charger light starts blinking. I'm using an Ideapad 100 15iBD

 

Mod's Edit: System model added to the front of Subject line to improve visibility / clarity.

 

Sr Support Specialist
Posts: 7,440
Registered: ‎11-30-2015
Location: PH
Views: 874
Message 4 of 4

Re: 100 15iBD - blank screen after lenovo logo

Hi Daisuke , 

 

Greetings. 

 

Hereon , I would consider that you call in technical support for a No POST repair specially if you have already tried reseating the memory and the harddrive removed .

 

It is receiving its power but fail to continue on the power on self test reading the BIOS firmware.

 

Regards



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Holiday Deals
HAPPENING NOW!

Get the best deals on PCs and tech now during the Holiday Sale
Shop the sale

Top Kudoed Authors