cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gibbogle
Fanfold Paper
Posts: 20
Registered: ‎09-29-2017
Location: NZ
Views: 5,209
Message 1 of 11

100s keyboard bizarre behaviour

The keyboard just started malfunctioning on this Ideapad 100s, which is about 6 months old.  On the 2nd row of alphabetic characters (starting with ‘A’) the only ones that work are ‘G’ and ‘H’.  If I disconnect and reconnect the battery the keys start working again, until at some point (maybe after logging off and on) the problem returns.  A USB keyboard works fine.  The bizarre thing is that plugging in a USB keyboard makes the 100s keyboard work, and it continues to work after unplugging the USB plug.  This makes me think the fault is not in the keyboard, but somewhere in the software.

The warranty has just expired – obviously the warranty period was judged to perfection.

I’m thinking there must be an easier trick to perform to get the keyboard working – surely Lenovo knows about this by now.

Remembers DOS
gibbogle
Fanfold Paper
Posts: 20
Registered: ‎09-29-2017
Location: NZ
Views: 5,206
Message 2 of 11

Re: 100s keyboard bizarre behaviour

Sorry for the repeated post - the first didn't seem to go. By the way, this is the 11IBY.
Remembers DOS
Vlad28
Paper Tape
Posts: 2
Registered: ‎10-08-2017
Location: UA
Views: 5,142
Message 3 of 11

Re: 100s keyboard bizarre behaviour

Hello! I have absolutely the same issue with my 100s.
Have you ever fixed that?

gibbogle
Fanfold Paper
Posts: 20
Registered: ‎09-29-2017
Location: NZ
Views: 5,132
Message 4 of 11

Re: 100s keyboard bizarre behaviour

Hi Vlad. No fix, and no response from Lenovo. Holding down the SHIFT key and one of the A row keys for many seconds sometimes restores functionality, for a while. I still can't decide whether this is a hardware or a software fault.
Remembers DOS
gibbogle
Fanfold Paper
Posts: 20
Registered: ‎09-29-2017
Location: NZ
Views: 5,096
Message 5 of 11

Re: 100s keyboard bizarre behaviour

I was contacted by a Lenovo techie - from Malaysia! That was a surprise, and even more surprisingly she seems to have fixed the problem. For some unknown reason the 100S had become configured with two different languages, US English and NZ English. Apparently this device must have only US English. After removing NZ English and rebooting, the keyboard is working fine. If it stays like this I'll be very happy.
Remembers DOS
ElCanto
Paper Tape
Posts: 3
Registered: ‎10-18-2017
Location: DE
Views: 5,055
Message 6 of 11

Re: 100s keyboard bizarre behaviour

hi gibbogle,

 

can you say me how you fix it?

gibbogle
Fanfold Paper
Posts: 20
Registered: ‎09-29-2017
Location: NZ
Views: 5,048
Message 7 of 11

Re: 100s keyboard bizarre behaviour

Apparently the problem was caused by having two languages selected. I was told that this device must have only US English. The fix was very simple:

Control Panel > Clock, Language and Region > Language

Make sure that English (United States) is selected.
Remove any other languages.
Then restart.

If you are not sure how to get to the Control Panel, Right Click on the Windows Icon (lower left corner of screen), then click Control Panel.
Remembers DOS
ElCanto
Paper Tape
Posts: 3
Registered: ‎10-18-2017
Location: DE
Views: 5,041
Message 8 of 11

Re: 100s keyboard bizarre behaviour

Thank you for you answer, but it didnt solved my problem... Smiley Sad

gibbogle
Fanfold Paper
Posts: 20
Registered: ‎09-29-2017
Location: NZ
Views: 4,994
Message 9 of 11

Re: 100s keyboard bizarre behaviour

It didn't fix mine either Smiley Sad It worked for a while, but now it's bad again. Obviously the language is not the issue.
I have now tried something else, and at the moment the keys are working, but who knows for how long?

I changed the Keyboard Properties, which I got to by:
Control Panel>Ease of Access>Ease of Access Center>Make the keyboard easier to use>Keyboard settings>Speed
I set the Repeat delay to the shortest, and Repeat rate to the fastest.
Fingers crossed!
Remembers DOS
Vlad28
Paper Tape
Posts: 2
Registered: ‎10-08-2017
Location: UA
Views: 4,698
Message 10 of 11

Re: 100s keyboard bizarre behaviour

Thank you for the answer. 
Have you ever tried to replace the keyboard? Any updates regarding your problem now?

Check out current deals!


Shop current deals

Top Kudoed Authors