cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MK-
Ctrl-Alt-Del
Posts: 5
Registered: ‎01-17-2019
Location: AE
Views: 374
Message 1 of 3

530s-14IKB not charging - MoBo fried?

I had this laptop less than 10 days. I bought it in another country. Worked properly before last night. 

 

I decided to upgrade SSD and as I was putting SSD metal cover back in place I saw a small flash. Laptop turned on but stopped charging. When plugged in battery indicator would show that laptop is charging for 5-10 seconds. After that it would stop and status would read “0 hours, 6 minutes to full charge”. 

 

I tried holding power button for 30 and 60 seconds, removing battery and holding the power button, resetting the button on the side of the laptop (NOVO?) When I remove battery cable alone also won’t allow the laptop to power on

 

Now the laptop is completely discharged and cannot power on. While this was happening charge light was solid amber the whole time. It seems like I fried the MoBo. There is no easy way to contact Lenovo service center in the country I’m currently in so is there anything else I can try to bring the laptop back to life. 

 

Btw, not blaming anyone but myself - it’s really strange that this would happen while returning a cover in it's place. I did these kinds of upgrades a dozen times on my other laptops and this is the first time something like this happened. 

 

Any my assistance would be much appreciated. Thanks. 

DonTango
Paper Tape
Posts: 1
Registered: ‎02-23-2019
Location: DE
Views: 292
Message 2 of 3

Re: 530s-14IKB not charging - MoBo fried?

Hello,

 

i am from Germany and i have the same Problem with my Ideapad 530S 14IKB.

 

Did you solve the Problem meanwhile?

 

Regards from Germany

MK-
Ctrl-Alt-Del
Posts: 5
Registered: ‎01-17-2019
Location: AE
Views: 269
Message 3 of 3

Re: 530s-14IKB not charging - MoBo fried?

Hi,

Yes but unfortunately it was by replacing the whole motherboard Smiley Sad

I hope your laptop is still in warranty.

Check out current deals!


Shop current deals

Top Kudoed Authors