cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
OlleN
Paper Tape
Posts: 1
Registered: ‎01-03-2018
Location: SE
Views: 692
Message 1 of 1

Boot failed and drive locked after Firmware update

I have already solved this issue myself, but perhaps I can help someone else with the same problem.

 

After installing the latest firmware on my Ideapad 700, I was met with a list of bootable devices (HDD + network cards), none of which worked.

 

To solve this, I put the Windows 10 installation on a USB flashdrive and booted from it, then navigated to the command prompt (Repair your computer -> Troubleshoot -> Advanced Options -> Command Prompt). From there, I entered the following commands:

diskpart
sel disk 0
list vol

I noticed that the wrong drive (the FAT32 system partition) had the letter C assigned, so I selected that one and changed it to a free letter:

sel vol 0
assign letter h:

Then changed my Windows drive back to C:

sel vol 1
assign letter c:
exit

I then rebuilt the boot sector (using the FAT32 system partition), just to be safe:

bootrec /fixboot
bcdboot C:\Windows /s h: /f
exit

Then, I rebooted and it went back to Windows! Hope this helps someone. Smiley Happy

Check out current deals!


Shop current deals

Top Kudoed Authors