cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
stencil
Fanfold Paper
Posts: 4
Registered: ‎12-24-2017
Location: US
Views: 4,571
Message 1 of 5

Flex 5 - Wifi Stops working

Hello,

 

I have 2 new Lenovo Flex 5 laptops. They both display the same problem, They both have the Qualcomm Atheros QCA61x4A Wireless Network Adapter. Every once in a while, the adapter just stops seeing all the networks near my computer.  A reboot fixes this. Going in the Device Manager and disabling and and then enabling the network adapter seems to work also. I have already updated the driver and the problem persists.  Is there a permenant solution to this? If this is a cheap network adapter, can I replace it with a high end one? What is a good one?

 

 

Moderator comment: Model added to subject for clarity.

jmt87
Punch Card
Posts: 9
Registered: ‎12-22-2017
Location: US
Views: 4,523
Message 2 of 5

Re: Wifi Stops working

Check this thread for possible answer. No promises, but maybe it will help:

 

https://forums.lenovo.com/t5/Lenovo-IdeaPad-100-305-500-Edge/Flex-2-15-wifi-problem/m-p/3714797

RAS2002
What's DOS?
Posts: 2
Registered: ‎12-29-2017
Location: US
Views: 4,457
Message 3 of 5

Re: Flex 5 - Wifi Stops working

This was extremely annoying. I just got my son a Flex 5 15" from Costco. Nice specs if a little big but it was his choice.

Anyway, our WiFi was going out everytime we connected with the laptop. It would be okay for possible a few minutes and then WiFi on the router would fail. A very new Netgear/modem combo. And the button to disconnect WiFi would not work on the front of the modem anymore either. However ethernet connections (wired) were still working. Bizarre!

So i went to update the drivers, but no ethernet connection on these laptops so i went and got an USB to ethernet adapter. I got the USB 3.0 Gigabit one because it had the send/receive/connected lights on the adapter but was another $10.

So now i could connect to the internet using a wired ethernet connection.

So fired up the laptop , WiFi immediately stopped working again on the router, and connected by ethernet to the internet. 

Earlier did disable DOS port scan protection on the router in case that would help but a few minutes later WiFi had failed again. So i left it in place and haven't gone back to enable it yet. I don't think it made any difference but for completeness here i am mentioning it.

So i am now connected via ethernet and i updated the bios and all drivers. No help. Said 'update driver' on Wifi, it got a much newer version, no help.

I uninstalled the WiFi and Bluetooth from the properties dialog. At this time WiFi was still down and i was not ready to power off and power on the router yet.

From the Lenovo download page i downloaded the intel and atheros drivers for bluetooth and Wifi to a local directory such as C:\LenovoDrivers\(All 4 drivers, 2 for each, intel and atheros(whatever the other was)).

I then manuall installed these by double clicking on each one and following the instructions.

Then i went into device manager and refreshed so these wifi bluetooth would show up again.

I then went in and disabled the Wifi and Bluetooth connections.

Then i powered off and on my router to get my Wifi working again.

I then enabled Wifi on the laptop.

I then went to connect to my Wifi network and just to be different chose the 5G network this time and entered the password and connected.

Wifi stayed up.

I then disconnected the LAN ethernet cable.

Wifi stayed up.

After about an hour or so i enabled the bluetooth connection.

Wifi stayed up.

It's only been a few hours but so far so good. I am kinda afraid to change anything for now.

It kinda sucks there isn't a more definitive solution as i am afraid that some windows update will undo what i did.

I looked at other threads on this stretching back years and people tried many things like replacing their router which didn't help. Since mine is a very new current model C6300 Netgear, and this didn't work for them, i don't see pursuing that at this time.

Thought about returning it but it seems a number of other manufacturers laptops have the same issue. It seems to be related to the atheros controller. Anyway you could possibly run into the same problem with another laptop and other than that, the Flex 5 seems okay and pretty fast so i will keep it for now and see what happens.

Flex 5 15 inch, 16GB memory,512GB SSD, FHD screen (not 4K), Intel 8th gen i7-8550 Costco special.

 

Hope this helps someone.

 

Ron

RAS2002
What's DOS?
Posts: 2
Registered: ‎12-29-2017
Location: US
Views: 4,238
Message 4 of 5

Re: Flex 5 - Wifi Stops working

Update to my previous post

Enabled DOS port scan protection on the router and no issues. 

This has now been working for over a month with no issues.

So far so good.

chrashing
Paper Tape
Posts: 1
Registered: ‎05-06-2017
Location: US
Views: 3,824
Message 5 of 5

Re: Flex 5 - Wifi Stops working

I've had 2 flex 5 1470 laptops which had  no or  slow wifi with the laptop on battery power. With the power adapter plugged, the wifi worked  fine. 

 

Here are instructions to fix this problem:

 

You will want to type in the search window of the task bar 'edit power plan', select it, then select: Change Advance Power Settings, then from the list presented select: Wireless Adapter Settings, Then select: Power Savings Mode, Finally change: On Battery to Maximum Performance.

 

I had returned the first Flex 5 I ordered because the wifi did not work when on battery power. The replacement Flex 5 worked better but the wifi was very slow on the battery. This change resolves the problem without significant impact on the battery life.
  

Check out current deals!


Shop current deals

Top Kudoed Authors