Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 2
Registered: ‎01-04-2017
Location: GB
Views: 1,093
Message 1 of 2

Ideapad 100-15IBD wireless problem


My Ideapad 100 has problems connecting to my Virgin Media Superhub 2.

When I first bought the laptop and tried to connect to my router I was asked to provide a Username and Password.

To resolve this issue I changed the security protocol on the router from WPA Auto to WPA2-AES.

When I rebooted the laptop the WiFi SSID was available but when I clicked connect and entered the WiFi password the laptop returned the error "Cannot connect to this network".

I ran the Windows Network Troubleshooter and it said that the security on the laptop does not match the security on the network.

I've now found that every time I reboot the laptop I have to change the security protocol on the router between WPA Auto and WPA2-AES to get the laptop to connect.


No other WiFi devices have difficulty connecting to the router so I suspect it's an issue with the laptop.


I've tried uninstalling the Realtek driver to use the Windows one and I've tried the latest driver from the Lenovo support site, all to no avail.


Any help or ideas would be appreciated.

Many thanks.

Paper Tape
Posts: 2
Registered: ‎01-04-2017
Location: GB
Views: 1,062
Message 2 of 2

Re: Ideapad 100-15IBD wireless problem

On further investigation it appears the problem lies with the Virgin Superhub rather than the laptop.

I set my iPhone as a WiFi hotspot and the laptop connected without any issues.


I'll contact Virgin Media for support with this but if anyone has had similar issues with Virgin I'd love to hear from them.

Check out current deals!

Shop current deals

Top Kudoed Authors