English Community

Lenovo NotebooksLenovo IdeaPad 1xx, 3xx, 5xx & 7xx, Edge, LaVie Z, Flex Notebooks
All Forum Topics
Options

30 Posts

08-08-2018

US

55 Signins

584 Page Views

  • Posts: 30
  • Registered: ‎08-08-2018
  • Location: US
  • Views: 584
  • Message 1 of 2

Ideapad 320 15-ABR performance

2018-08-08, 14:33 PM

Very recently I've had issues where processes are consuming a lot of CPU usage and very little RAM. On average my CPU will be consumed between 40-98 %. The RAM however is barely being touched, maybe 50% at max!

 

The problem happens if I use Firefox, Chrome, Edge or playing any video. I have tried things like Reinstalling the OS, reinstalling drivers and updating drivers and checking for Windows updates -- everything is up to date.

 

The only thing I haven't tried yet is doing anything with the BIOS. The problem happened just after Lenovo Vantage recommended a BIOS update due to a security issue.

 

I've looked online to see if I could possibly downgrade and none are provided. I've been Googling and no one else seems to really have this issue. Any help would be appreciative.

 

Just fyim about the only thing I haven't tried is downgrading the BIOS. I have tried Reinstalling the BIOS but no change.

Solved! See the solution
Reply
Options

808 Posts

07-10-2016

GB

3141 Signins

83642 Page Views

  • Posts: 808
  • Registered: ‎07-10-2016
  • Location: GB
  • Views: 83642
  • Message 2 of 2

Re: Ideapad 320 15-ABR performance

2018-08-08, 17:08 PM

 wrote:

The problem happened just after Lenovo Vantage recommended a BIOS update due to a security issue.


Read this thread:

 

https://forums.lenovo.com/t5/Lenovo-IdeaPad-1xx-3xx-5xx-7xx/Ideapad-320-15abr-5QCN22WW-Bios-Update/td-p/4139755

 

-- from CyberSimian in the UK

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save