cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TKJ1
Paper Tape
Posts: 1
Registered: ‎04-25-2018
Location: ZA
Views: 66
Message 1 of 2

Keyboard -keys are different to what is displayed on key

I have had my Ideapad 520 for a just over a year now and I have not been able to find a solution to this problem.

 

As an example, the numeric key where 2 is at the bottom and @ is above it.  On pressing Shift 2 I don't get the @ I get ".  If i want to type @, I have to use the " key.  If I press shift + numeric key starting from 1, this is what I get:  ! " £ $ % ^ & * ( ) _ +, so the # key displays a £.  I have no backslash key as the key that is supposed to be a backslash is a # instead.

 

  I have changed to different keyboard languages eg. US and UK etc and this does not make any difference.  I have also asked for assistance with this last year and got no response.  When i google, I get told to change the keyboard language which I have tried.

 

Yes, I have lived with this for a year now, but it would be nice to get all the keys to work as they're supposed.  I probably will never buy another Lenovo because of this.  Also, my Lenovo shock me in charging mode - also not great.

 

tnx

Tracy.

CyberSimian
Bit Torrent
Posts: 773
Registered: ‎07-10-2016
Location: GB
Views: 28
Message 2 of 2

Re: Keyboard -keys are different to what is displayed on key


@TKJ1 wrote:

the numeric key where 2 is at the bottom and @ is above it.  On pressing Shift 2 I don't get the @ I get ".  If i want to type @, I have to use the " key.  If I press shift + numeric key starting from 1, this is what I get:  ! " £ $ % ^ & * ( ) _ +


That sequence corresponds to my UK keyboard, but you evidently have a keyboard intended for some other country which has a different keyboard layout. Do you know what country your keyboard is intended for?  You show your location as "ZA".  What is that? Zambia?  Do you have a laptop with a Zambian keyboard?  Where did you buy your laptop?

 

The solution is the one that you have already tried, namely to adjust the settings in Windows so that Windows is using the correct keyboard layout.  So either you did not use the keyboard setting dialogue correctly, or you are still specifying the wrong keyboard layout.

 

I have just googled for "keyboard layouts by country". One of the hits is the following page which illustrates numerous different keyboard layouts.  See if you can identify your keyboard layout:

 

https://sites.google.com/site/brightmeasurement/Home/keyboard-for-english-around-the-word

 

-- from CyberSimian in the UK

Check out current deals!


Shop current deals

Top Kudoed Authors