Showing results for 
Search instead for 
Did you mean: 
Fanfold Paper
Posts: 8
Registered: ‎04-28-2017
Location: US
Views: 2,012
Message 1 of 5

Lenovo warranty replaced Elan touchpad with Synaptics, confusing BIOS, can't install.

My god, I am livid right now. I have a Flex 4, and instead of being able to buy a simple ENTER key or replace the keyboard, Lenovo had me send the whole computer off for warranty service. Great, no cost to me, right?


When I got it back, I got back a computer with MORE problems than I sent it off with. First: a constant nagging "USB Device Not Recognized" popup that disappears and reappears every 20 seconds or so (with the accompanying device unplug/replug sound). Second: the touchpad is completely unusable. Have to mash my whole finger on the pad to move the cursor around (the touchpad was already the worst part of this computer - stupid single-piece thing!), and two-finger scrolling doesn't work.


Looking at the control panel for the Elan touchpad (advanced mouse settings), it reports a "Standard PS/2 mouse", meaning that the underlying hardware is no longer Elan. What happened? Well, I'll take a wild guess: the "PS/2" implementation is partly software emulation, and the BIOS (EFI, ACPI, etc) has it in its head that an ELAN pad is connected, and when the dopes at the warranty service center swapped out the entire body of my computer to replace an Enter key, they put a chassis with a Synaptics touchpad in place of what used to be Elan.


So, BIOS reports to Windows that an ELAN pad is connected, but under the hood, it's actually a Synaptics driver.


When I force-install the Synaptics driver over the Elan one, it works great. Synaptics control panel reports that it's a ClickPad v8.9 (which is information it pulls from the hardware, not software), so a Synaptics touchpad is legitimately installed -- but the ACPI device is listed as *ETD0672 - so Windows always, and I mean, aggressively, ALWAYS, forces the Elan driver to be installed. It's only through some acts of Windows hacking that I'm able to keep the Synaptics driver installed. Windows keeps wanting to replace it with the Elan driver...


So, Lenovo  by taking my mostly-working PC, replacing the chassis for an Enter key, the chassis containing a different touchpad brand, and didn't even have the knowledge to configure the system for the new touchpad. Though they must've booted it up, what'd they do, just see that words came on the screen? Didn't check that the touchpad worked correctly, didn't even notice the "USB Device Not Recognized" popups every few seconds...


Watch: next, I'll be asked to reinstall Windows.


Mod's Edit: Posting edited to conform to Forum Rules.


Fanfold Paper
Posts: 8
Registered: ‎04-28-2017
Location: US
Views: 1,983
Message 2 of 5

Re: Lenovo warranty replaced Elan touchpad with Synaptics, confusing BIOS, can't instal

Big update!


As predicted, the problem WAS caused by the hardware swap, and the BIOS (or firmware) had "cached" the identity of the touchpad module in persistent memory.


However, thankfully, the "Load defaults" function of the BIOS (eh, UEFI firmware) settings page DID actually reset everything - and it prompted the system to re-detect the attached device. So, when I loaded defaults and rebooted (though I'd changed none of the settings in the pages), the system powered off, powered up, powered off again, powered on, booted Windows, and detected the correct device - ACPI\SYN2B89 - a Synaptics touchpad, which auto-installed the correct driver.


This is NOT an OS reinstall (actually, using the OS reinstall/restore would not have fixed this). It does not affect your Windows environment or data in any way.


So, to fix this, for anyone in the future (you might want to pull this up on your phone - here's a QR code):

1) Click Start menu, type "advanced". Select the "Change advanced startup options" item.

2) Under the "Advanced Startup", click the Restart button.

3) When you get to the selections page, select Troubleshooting (maybe a "More" or "Other" option first), and then select "Change UEFI firmware settings".

4) Once the PC reboots, go to the last tab, "Exit", I think. At the bottom of the list is an option for "Load default settings". Select that.

5) Finally, after you've "loaded" the defaults, select "Save and Reboot".

6) The PC will power-cycle a few times, then go back and boot Windows normally.

7) Your touchpad may respond erratically at first. Check with the Device Manager to see if the "Standard PS/2 port  mouse" has been replaced with the correct driver. If it doesn't auto-install on its own, help it along by either checking for Windows updates, or right-click and update the driver manually. Once installed, it'll ask to reboot

8) Finally, reboot again, and your touchpad should work just like normal again!


Hope this helps someone.


I still have the mind-numbingly frustrating problem of an unknown USB device plugging/unplugging every 15 seconds like clockwork, though. "USB port reset failed". Ughh...


Mod's Edit: Subject line edited to conform to Forum Rules.

What's DOS?
Posts: 1
Registered: ‎07-14-2017
Location: US
Views: 1,873
Message 3 of 5

Re: Lenovo warranty replaced Elan touchpad with Synaptics, confusing BIOS, can't instal

Thank you for posting this as I had a very similar situation were a friend had bad keys on the original keyboard. He replaced the whole topcover and everything other than multi touch functions worked. His old touchpad must have been a synaptics because that was teh driverset that was installed. I followed your instructions and now it recognizes as a Elan device not ps/2 compatible and all the functions are working after a quick driver update. My friend thanks you as well as the jungles of Ecuador do not really have computer techs.

What's DOS?
Posts: 2
Registered: ‎01-07-2018
Location: RO
Views: 1,332
Message 4 of 5

Re: Lenovo warranty replaced Elan touchpad with Synaptics, confusing BIOS, can't instal

Thanks for this tip, I had the exact issue: changed my topcover and it came with a different touchpad. After reseting the BIOS to defaults, everything worked fine!
Kudos !
What's DOS?
Posts: 1
Registered: ‎01-11-2019
Location: US
Views: 579
Message 5 of 5

Re: Lenovo warranty replaced Elan touchpad with Synaptics, confusing BIOS, can't instal

THANK YOU SO MUCH FOR THIS!!!!   A tech came (under my Lenovo in-home warranty program) and swapped out my keyboard and touchpad. When he finished and I started up my computer I told him it was not working correctly. He said it was a software thing and left. (I had in-home warranty). I called customer service. They told me to back up my computer (2 hours), then they had me reset my computer (another 2 hours). I called back. They still couldn't get it to work. I was then transferred to the 'Premier Software Support' and was told I would have to pay for any help they gave me (even though this was an issue because of Lenovo). I got upset and hung up the phone. I have been Googling for the past couple of days searching for answers (since Lenovo couldn't help me). This did it. Now sadly I have to reinstall all of my programs, setup Outlook once more. All that fun stuff....  I wish someone at Lenovo knew about this and it could have been installed before my computer was wiped.


The thing is, I had a feeling it might be something like this. I just didn't know how to fix it. I kept asking if he replaced like for like or if the replacement part was from another company. No one listened.



Check out current deals!

Shop current deals

Top Kudoed Authors