cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ksukat
Paper Tape
Posts: 1
Registered: ‎02-21-2019
Location: US
Views: 72
Message 1 of 1

ideapad 320 15IAP-does not appear to boot after memory upgrade

My wife purchased this Ideapad 320-15IAP from Walmart 1 year ago.  It has 4GB's of RAM.   She wanted more RAM to run some more intensive applications.   I went  to crucials website ran their scan tool and purchased the stick it recommended.

 

When the new stick of ram arrived I took the notebook, watched youtube videos on how to safely open it.  Did so and unhooked the battery.  removed the original stick.  Installed new stick. Plugged battery back in.  Put back on.  Plugged charger in.  Pressed power button and the light on the button came on, but nothing come on the screen.  It remained black.   Pressed and held power button for 5 count until light went out.  Removed charger.  Removed back.  Unplugged battery.  Reseated new stick of memory.   Powered on, same story.

 

Thinking the new  memory stick was bad, opened the notebook back up and replaced the new memory stick with the original  and hit the power button with the same result.

 

Then drained system by unplugging battery, power charger and holding power button down for 60 seconds.   Reconnect battery and charger.  Same result.

 

Screen worked minutes before the attempted  memory upgrade.  Any ideas how to get this straightened out?

 

I tried using the nuovo button but it did absolutely  nothing.

 

thanks in advance.

Check out current deals!


Shop current deals

Top Kudoed Authors