English Community

Datacenter StorageLenovo Iomega Networking Storage
All Forum Topics
Options

6 Posts

04-13-2014

Sterling Heights, Michigan

5 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎04-13-2014
  • Location: Sterling Heights, Michigan
  • Views: 30
  • Message 1 of 8

NFS Permissiion Denied error

2014-04-13, 19:54 PM

I have just acquired two new Lenovo Ix2 NAS units. This is in addition to the two older iomega branded IX 2's alreadu ion my network. I have cionfigured the new IX2's, with Sevurity off, NFS enabled, Allow all client users full access.

 

(The same settings as on my older Iomega's.)

 

I attempt to access from my unix machine using

 

cd /net/hostname/nfs/Backups

 

I get a permission denied error.

 

Note that on my older iomegas's the path was different as follows:

 

cd /net/hostname/mnt/pools/A/A0/Backups

 

Also, on the older units I could progressively access the correct directory as in

 

# cd /net/iomegaix2
# ls -la
total 3
dr-xr-xr-x   2 root     root           2 Apr 13 16:42 .
dr-xr-xr-x   2 root     root           2 Apr 13 16:37 ..
dr-xr-xr-x   1 root     root           1 Apr 13 16:42 mnt
# cd mnt
# ls -la
total 3
dr-xr-xr-x   2 root     root           2 Apr 13 16:44 .
dr-xr-xr-x   2 root     root           2 Apr 13 16:42 ..
dr-xr-xr-x   1 root     root           1 Apr 13 16:44 pools
# cd pools
# ls -la
total 3
dr-xr-xr-x   2 root     root           2 Apr 13 16:44 .
dr-xr-xr-x   2 root     root           2 Apr 13 16:44 ..
dr-xr-xr-x   1 root     root           1 Apr 13 16:44 A
# cd A
# ls -la
total 3
dr-xr-xr-x   2 root     root           2 Apr 13 16:44 .
dr-xr-xr-x   2 root     root           2 Apr 13 16:44 ..
dr-xr-xr-x   1 root     root           1 Apr 13 16:44 A0
# cd A0
# ls -la
total 8
dr-xr-xr-x   7 root     root           7 Apr 13 16:44 .
dr-xr-xr-x   2 root     root           2 Apr 13 16:44 ..
dr-xr-xr-x   1 root     root           1 Apr 13 16:44 Backups
dr-xr-xr-x   1 root     root           1 Apr 13 16:44 Documents
dr-xr-xr-x   1 root     root           1 Apr 13 16:44 Movies
dr-xr-xr-x   1 root     root           1 Apr 13 16:44 Music
dr-xr-xr-x   1 root     root           1 Apr 13 16:44 Pictures
dr-xr-xr-x   1 root     root           1 Apr 13 16:44 TimeMachine
# cd Backups
# ls -la
total 65
drwxrwxrwx   7 99       100         4096 Jul 29  2012 .
dr-xr-xr-x   7 root     root           7 Apr 13 16:44 ..
-rw-rw-rw-   1 99       100         4488 Sep 19  2011 DefaultPicture.png

On the new lenove version I get the following

 

#
#
# cd /net/lenovoix2
# ls -la
total 3
dr-xr-xr-x   2 root     root           2 Apr 13 16:47 .
dr-xr-xr-x   3 root     root           3 Apr 13 16:37 ..
dr-xr-xr-x   1 root     root           1 Apr 13 16:47 nfs
# cd nfs
nfs: permission denied
#

 

 

Firmware revision is 4.0.6.19294

 

Any Ideas how to fix this?

What do I need to do on the Lenovo vesion that was not required on the iomega version?

 

Thanks,

Don

 

 

Reply
Options

1610 Posts

09-12-2013

Orem, UT

940 Signins

15739 Page Views

  • Posts: 1610
  • Registered: ‎09-12-2013
  • Location: Orem, UT
  • Views: 15739
  • Message 2 of 8

Re: NFS Permissiion Denied error

2014-04-13, 20:46 PM

Hi dgietzen,

 

When connecting to an NFS share on your NAS device, make sure the file path contains all lower case characters.

 

I would also recommend upgrading to the latest firmware: Firmware Version 4.0.8.23976 for ix2 and ix2-dl

 

 

Have questions and need answers?

Search the database for answers to FAQ's, software/driver downloads, tutorials, news, features and more!

LenovoEMC Support & Downloads

LenovoEMC North America Support Contact Page
Reply
Options

6 Posts

04-13-2014

Sterling Heights, Michigan

5 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎04-13-2014
  • Location: Sterling Heights, Michigan
  • Views: 30
  • Message 3 of 8

Re: NFS Permissiion Denied error

2014-04-13, 21:30 PM

I have attempted all lowercase letters as in:

 

# cd /net/lenovoix2/nfs/backups
/net/newton/nfs/backups: permission denied
#

Note that in the older version of firmware I would use

 

# cd /net/iomegaix2/mnt/pools/A/A0/Backups
# pwd
/net/einstein/mnt/pools/A/A0/Backups
#

 

Which successfully mounts the file system.

 

Note thet Ubix recognises upper and lower case directory names, so using Caps, if that is what the actual name was created with should work. In fact not allowing caps in a directory name is likely a violation of the NFS v4 spec.

 

Lastly atttempting all lower case on the older iomega variant as in

 

# cd /net/iomegaix2/mnt/pools/a/a0/backups
/net/einstein/mnt/pools/a/a0/backups: does not exist
#

fails as it should per NFS specs

 

I have looked at the readme for 4.0.8.23976, it says nothing about enhancements of fixes to NFS.

 

None the less I will attempt this upgrade and hope that it does not turn my new IS2 into an expensive brick. (I have seen this happen with unfortunate frequency when doing firmware upgrades to storage devices...

 

Will report back on results...

 

Don

 

 

 

 

Reply
Options

6 Posts

04-13-2014

Sterling Heights, Michigan

5 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎04-13-2014
  • Location: Sterling Heights, Michigan
  • Views: 30
  • Message 4 of 8

Re: NFS Permissiion Denied error

2014-04-13, 22:07 PM

OK, I updated the IX2 to Firmware 4.0.8.23976.

 

No Joy.


When going to the Shares screen under the Backups share and pulling down the NFS pulldown I see the following:

 

Location: /nds/Backups

NFSv4 Location: /Backups

 

 

Attempts t mount (Upperr case and lower case as fiollows

 
# cd /net/lenovoix2n/nfs/Backups
/net/lenovoix2/nfs/Backups: permission denied
#

# cd /net/lenovoix2/nfs/backups
/net/lenovoix2/nfs/backups: permission denied
#

# cd/net/lenovoix2/Backups
cd/net/lenovoix2/Backups: not found
#

# cd /net/lenovoix2/backups
/net/lenovoix2/backups: does not exist
#
 
 
Clearly the path must be nfs/backups, either uppercase or lowercase seems to work, as this gives a permission error, as opposed ti not usig the nfs directory name which indicates a directory not found erroe.
 
What now??
 
Don
 
 
Reply
Options

1 Posts

04-14-2014

Edinburgh, Scotland

4 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎04-14-2014
  • Location: Edinburgh, Scotland
  • Views: 10
  • Message 5 of 8

Re: NFS Permissiion Denied error

2014-04-14, 13:58 PM

Hi,

 

Not meaning to dump on your post but I am also getting permission errors when using NFS.

 

I am, however, using a newly aquired ix4-200d (Cloud Ed.) with latest firmware.

 

When I create directories or files (as root) they always end up with user 99:users.

 

# ls -la

drwxr-xr-x  2   99 users    6 2014-04-14 10:29 dir1
-rw-r--r--  1   99 users    0 2014-04-14 10:55 file1

 

# chown root: file1

chown: changing ownership of `file1': Operation not permitted

 

I'm using the default NFS mount options.

 

Steve

Reply
Options

1610 Posts

09-12-2013

Orem, UT

940 Signins

15739 Page Views

  • Posts: 1610
  • Registered: ‎09-12-2013
  • Location: Orem, UT
  • Views: 15739
  • Message 6 of 8

Re: NFS Permissiion Denied error

2014-04-14, 21:47 PM

Are you using VMware to connect? VMware has not updated to NFSv4, which is what our newer devices use so you will have to mount as NFSv3 with the prefix "/nfs/" which it seems like you have already tried. Our older devices use NFSv3. Also, with our newer devices you may have to add an NFS rule to the share if it is a secured share.

 

Enabling NFS Secured Access

 

1. To enable NFS, first click the switch on from the Protocols page.

 

2. On the Shares page, select a secure Share and expand the NFS section. You cannot apply a rule to an unsecured Share.

 

3. Click Add an NFS rule to add a Host Name for the rule. Rules are added to specify the hosts that are allowed to access Shares using NFS. Use this table to add NFS rules to specify access for hosts. For example, *.cs.foo.com matches all hosts in the domain cs.foo.com. To export a Share to all hosts on an IP address or local network simultaneously, specify an IP address and netmask pair as address/netmask where the netmask can be in dotted-decimal format, or as a contiguous mask length. For example, either /255.255.252.0 or /22 will result in identical local networks.

 

4. When the rule is added, read access is automatically set to the Share. Select Write to allow users to write to that Share. Use and to modify the rule priority for NFS access.

 

5. Click Apply to save your changes.

 

 

One last thing to check is the GID value for the user. Go to the Users & Groups page and select the user. Expand the Information tab to view the GID value. The GID value must be the same on both the Linux client and the NAS for the client to access files. To modify the GID, type a new GID value.

Have questions and need answers?

Search the database for answers to FAQ's, software/driver downloads, tutorials, news, features and more!

LenovoEMC Support & Downloads

LenovoEMC North America Support Contact Page
Reply
Options

6 Posts

04-13-2014

Sterling Heights, Michigan

5 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎04-13-2014
  • Location: Sterling Heights, Michigan
  • Views: 30
  • Message 7 of 8

Re: NFS Permissiion Denied error

2014-04-15, 1:34 AM

OK,

 

Firstly, Thanks for getting back to me, but your suggestion doesn't really solve the problem...

 

No I am not using VMware to connect. The client machine is running Solaris 10 which supports both NFSv3 and v4

 

As I believe I stated earlier, I am running the IX2 with UNSECURED SHARES. Security is Turned Off, No users or groups are defined.

 

I have enabled NFS on the protcol page.

 

I have set settings to "Allow ALL Client Users Full Access"

 

My invironmnet is limited, and not exposed to the internet, or a larger networked community, so security is not an issue.

 

The primary use of these devices, as regards the Unix servers, is for backup. This is accomplished via shell scripts, run as root on the Solaris client, that utilize automount. The scripts force the mounting of the shared directory by referncing it using the cd command in the form cd/net/hostname/directorypath.

 

This is a mechanism that has already been deployed, and in use for several years using earlier versions of the IX2.

 

Your note, from the manual, that"You cannot apply a rule to an unsecured Share." is clearly accurate, the share IS UNSECURED by design.

 

The conclusion that I must draw form your response is that, despite my desire to proceed with an unsecured environment, your latest version of the IX NAS software REQUIRES me to create a sucred environment in order to use NFS at all, regardless of wheather I want to or not.

 

I am concermed that if I do set up security and define users and/or groups just to make NFS usable, that I will

 

1.-  Potentially create issues of access and password requirements for other non-NFS users, who hav no issues cuurrenttly wiith the other protocols in use (such as windows file sharing) and

 

2.- Will create additional, and ongoing, work for myself maintaining a security framework that I didn't need or want in the first place.

 

Your documentation does not suggest that NFS MUST BE a secured environmnet, only what I must do if I have a sucured environmnet

 

Do I have any alternative short of returning your product and finding a more flexable NAS solution?

 

Don

 

 

Reply
Options

6 Posts

04-13-2014

Sterling Heights, Michigan

5 Signins

30 Page Views

  • Posts: 6
  • Registered: ‎04-13-2014
  • Location: Sterling Heights, Michigan
  • Views: 30
  • Message 8 of 8

Re: NFS Permissiion Denied error

2014-04-15, 2:47 AM

Some interesting additional info.

 

I decided to attempt static mounts as an alternative, just toi see if this created permission issues.

 

I used the command

 

mount -F nfs -o rw newton:Backups /mnt

 

on the server. (mount the filesuystem Backups for read/write at the directory /mnt

 

This works

 

I get the following mounted file system

 

mount -p

.

.
lenovoik2:Backups - /mnt nfs - no rw,xattr

 

and I can read anbd write to the mounted directory.

 

While this is a viable workaround, it still begs the question of why the automount form fails with a permision issue.

 

/etc/auto_master contains

# Master map for automounter
#
+auto_master
/net            -hosts          -nosuid,nobrowse
/home           auto_home       -nobrowse

 

This should work to achieve the same thing (Note I have also used the nosuid andd nobrowse options on the static mount command. It still works)

 

Any ideas?

 

Don

 

 

 

 

Don

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms