English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks Knowledge Base

IdeaPad P580 - Touchpad is not responding - gestures and scrolling are not working


I just bought a P580 IdeaPad and it doesn't seem to understand any kind of gestures or scrolling using the Touchpad.


I looked through the manual and I couldn't find anything about it either.


When I started up the machine, the only driver it had installed by default for the mouse was a default "Microsoft PS/2 Mouse".


I tried downloading and installing the P580 touchpad driver from the Lenovo website, but that didn't make much difference either. Windows 7 picked the ELAN driver as the matching driver, and still no luck in terms of gestures or scrolling.


It's a wide screen, and it's a lot of work to move your cursor across the screen to do simple things like scrolling.


The correct touchpad drivers should be installed in order to provide the advanced functions of the touchpad.  If generic mouse / touchpad drivers are installed or the incorrect touchpad driver is installed, some features may not be available, and the touchpad may function erratically.


The Touchpad driver package for the P580 actually includes driver for the 3 different manufacturers of touchpad, Cypress, Synaptics and ElanTech which could used in the P580.  


Go to Lenovo's support site and download the "Touchpad" driver package for your version of Windows.


Touchpad driver package for Windows 7 users


Touchpad driver package for Windows 8 users


Prior to installing the driver, please open device manager and confirm the touchpad version in your particular system.  Synaptics is used the follow install example.



  • Install it.
  • Go to C: > drivers > TouchPad Driver (Cypress, Synaptics, ElanTech)
  • Go to Synaptics > ClickPad
  • Right-click on "Setup" and run as "Administrator"


If the option for Synaptics was not automatically chosen,

  • (While in "View by: Small icon") Mouse > Hardware
  • Choose "Lenovo pointing device"

Was this information helpful?

Yes No


Sarah94 On 2012-10-11, 1:27 AM

I'm having a similar issue, the scroll function is not working on my laptop's touchpad. Were you able to get it fixed?


Synaptics is installed and updated, correct driver is selected, all other functions seem to work fine, laptop is a P580

maxbiaggi On 2012-11-15, 13:56 PM

I'm having the same problem with the default driver (microsoft ps2 mouse) being selected. My issue is that I'm running Windows 8 64 bit on an ideapad Z580.


When I download the Synaptics Touchpad driver for Microsoft windows 8  (32 bit, 64 bit) Ideapad 

I try to install it and I eventually get this error message.


"You have to run the 64 bit version of DPinst.exe on this machine. Please contact the vendor that provided you with this package"


What do I do next??

husain1082 On 2013-07-13, 17:57 PM

Hi ,


My lappy G580 touchpad sometimes does not respond and somtimes it works well . I usually use a USB mouse for my use .Kindly help

Cleo_Lenovo On 2013-09-11, 21:03 PM
Tariq92 On 2015-04-24, 14:42 PM

my lenovo ideapad s510 touch. touchpad hardware not shown in mice and other pointing device. plz fix this problem.

nottechsavvy On 2015-10-15, 15:33 PM

I just had my ideapad s510p cleaned out and windows 8.1 installed. Now my touchpad gestures like scrolling and zoom in/out etc. arenot working. I went to look uptrackpad and I don't have that listed any more. I only see mouse ps/2. I know before I had my computer cleaned out I had Synaptics(?) listed as my mouse device. What do I need to do to get back to the way it was before? I hope this makes sense. Not real tech savvy. Thanks

anubhav007 On 2016-08-13, 7:20 AM

Hello everyone!!!


I used to have the same issue of multi gesture & scrolling not working on my lenovo y50-70.

But i found a solution & it's going to work 100% for you too!


(windows 8.1 or 10..... doesn't matter)


I made a step by step video to resolve this issue on my YouTube Channel.


Check it out, Here's the link :-




PS: I hope this will resolve your issue, if you still got some questions for me, just ask, either here or comment on this video tutorial


Have a nice day everyone! :)

Yeoh On 2016-12-26, 3:28 AM

I have a similar problem. My Labtop is Ideapad 500S. After using for about 2 months, the touch pad is not responding. What should I do?

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop