Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Gaming – Lenovo LegionGaming Laptops
All Forum Topics
Options

38 Posts

06-14-2016

India

325 Signins

4040 Page Views

  • Posts: 38
  • Registered: ‎06-14-2016
  • Location: India
  • Views: 4040
  • Message 1 of 4

Legion 5i hybrid graphics mode issue

2020-10-27, 6:42 AM

My laptop legion 5i (i5 10300h 8gb ram GTX 1650 120hz panel) has a an issue when running on hybrid mode. When the laptop is put into hybrid graphic mode (which uses both intel HD and Nvidia GPU efficiently according to the usage) the display brightness varies in a weird manner.ie, When a pitch black window is opened brightness lowers automatically and when I come back to desktop which has a light background the brightness returns to normal. I am now using the laptop with hybrid mode off and it uses only the Nvidia GPU and i face no issues in this mode. But i cannot use it in this mode for long as i get substantially low battery life when compared to hybrid mode. Anyone else face this issue? Can anyone suggest a fix?

IamNived
Reply
Answer
Options

2834 Posts

03-11-2020

Greece

331 Signins

14366 Page Views

  • Posts: 2834
  • Registered: ‎03-11-2020
  • Location: Greece
  • Views: 14366

Re:Legion 5i hybrid graphics mode issue

2020-10-27, 11:02 AM

Hi nived007,

 

Welcome to the Community Forums.

 

Here is a few troubleshooting steps you can try to remedy this issue:

 

Step 1. Disabling Power Saving Technology For Intel Graphics cards:

- Get into the Intel(R) HD Graphics Control Panel (CUI)

- Go to the "Power" section

- On the left navigation panel, select the "On Battery" option

- Pick "Display Power Saving Technology" | "Disable"

 

Step 2. Disable the Adaptive Brightness Feature in Windows:

- Go to "Control Panel" > "Hardware and Sound" > "Power Options"

- Next to your active power plan, click on "Change plan settings"

- Below, click on "Change advanced power settings"

- Scroll down to "Display" and expand "Enable adaptive brightness"

- Set both "On battery" and "Plugged in" modes to "Off"

- If the issue persists:

 

- Press Windows S and launch "Task Scheduler"

- Go to "Task Scheduler Library" and expand it

- Expand "Microsoft" > "Windows"

- Select "Display"

- Choose "Brightness" and disable or delete the task "BrightnessReset"

- If the issue persists, continue below:

 

Step 3. - Disabling Automatic Hardware Driver updates:

- Right click the Windows Icon, select the "Search" Function.

- Type "Control Panel" and select "Small icons" or "Large Icons" in the "View By" top right.

- Click the "System Icon"

- Navigate to "Advanced System Settings" -> "Hardware"

- Click "Device Installation Settings" and Select "No"

**This will prevent Windows from interfering with your hardware drivers in future updates, but keep crucial security updates rolling.

 

Step 3.2 - Uninstall Display Device with drivers and reinstall:

- Press the Windows key + X and select "Device Manager"

- Expand "Display Adapters"

- Right click the AMD, NVIDIA and/or INTEL VGA devices and select "Uninstall"

- If prompted to uninstall drivers associated with the device, tick the box and continue.

- Perform a restart of the laptop. 

 

Hopefully one of these will sort the issue,

 

Regards

 

Voithos



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Private Message; questions belong in the forums.

Reply

Replies(3)
Answer
Options

2834 Posts

03-11-2020

Greece

331 Signins

14366 Page Views

  • Posts: 2834
  • Registered: ‎03-11-2020
  • Location: Greece
  • Views: 14366
  • Message 2 of 4

Re:Legion 5i hybrid graphics mode issue

2020-10-27, 11:02 AM

Hi nived007,

 

Welcome to the Community Forums.

 

Here is a few troubleshooting steps you can try to remedy this issue:

 

Step 1. Disabling Power Saving Technology For Intel Graphics cards:

- Get into the Intel(R) HD Graphics Control Panel (CUI)

- Go to the "Power" section

- On the left navigation panel, select the "On Battery" option

- Pick "Display Power Saving Technology" | "Disable"

 

Step 2. Disable the Adaptive Brightness Feature in Windows:

- Go to "Control Panel" > "Hardware and Sound" > "Power Options"

- Next to your active power plan, click on "Change plan settings"

- Below, click on "Change advanced power settings"

- Scroll down to "Display" and expand "Enable adaptive brightness"

- Set both "On battery" and "Plugged in" modes to "Off"

- If the issue persists:

 

- Press Windows S and launch "Task Scheduler"

- Go to "Task Scheduler Library" and expand it

- Expand "Microsoft" > "Windows"

- Select "Display"

- Choose "Brightness" and disable or delete the task "BrightnessReset"

- If the issue persists, continue below:

 

Step 3. - Disabling Automatic Hardware Driver updates:

- Right click the Windows Icon, select the "Search" Function.

- Type "Control Panel" and select "Small icons" or "Large Icons" in the "View By" top right.

- Click the "System Icon"

- Navigate to "Advanced System Settings" -> "Hardware"

- Click "Device Installation Settings" and Select "No"

**This will prevent Windows from interfering with your hardware drivers in future updates, but keep crucial security updates rolling.

 

Step 3.2 - Uninstall Display Device with drivers and reinstall:

- Press the Windows key + X and select "Device Manager"

- Expand "Display Adapters"

- Right click the AMD, NVIDIA and/or INTEL VGA devices and select "Uninstall"

- If prompted to uninstall drivers associated with the device, tick the box and continue.

- Perform a restart of the laptop. 

 

Hopefully one of these will sort the issue,

 

Regards

 

Voithos



Did someone help you today? Press the thumbs-up icon below to thank them with a Kudos!!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Please don't ask me questions by Private Message; questions belong in the forums.

0 person found this solution to be helpful.

This helped me too

Reply
Options

38 Posts

06-14-2016

India

325 Signins

4040 Page Views

  • Posts: 38
  • Registered: ‎06-14-2016
  • Location: India
  • Views: 4040
  • Message 3 of 4

Re:Legion 5i hybrid graphics mode issue

2020-10-28, 8:13 AM

Going into intel graphics command center and disabling the display power saving mode seems to have solved the issue. Need to do more testing to confirm the problem as solved.

Thanks a lot for the quick reply👌

 

 

 

@ Voithos wrote:
 

 

Hi nived007,

 

 

 

Hi nived007,

 

Welcome to the Community Forums.

 

Here is a few troubleshooting steps you can try to remedy this issue:

 

Step 1. Disabling Power Saving Technology For Intel Graphics cards:

- Get into the Intel(R) HD Graphics Control Panel (CUI)

- Go to the "Power" section

- On the left navigation panel, select the "On Battery" option

- Pick "Display Power Saving Technology" | "Disable"

 

Step 2. Disable the Adaptive Brightness Feature in Windows:

- Go to "Control Panel" > "Hardware and Sound" > "Power Options"

- Next to your active power plan, click on "Change plan settings"

- Below, click on "Change advanced power settings"

- Scroll down to "Display" and expand "Enable adaptive brightness"

- Set both "On battery" and "Plugged in" modes to "Off"

- If the issue persists:

 

- Press Windows S and launch "Task Scheduler"

- Go to "Task Scheduler Library" and expand it

- Expand "Microsoft" > "Windows"

- Select "Display"

- Choose "Brightness" and disable or delete the task "BrightnessReset"

- If the issue persists, continue below:

 

Step 3. - Disabling Automatic Hardware Driver updates:

- Right click the Windows Icon, select the "Search" Function.

- Type "Control Panel" and select "Small icons" or "Large Icons" in the "View By" top right.

- Click the "System Icon"

- Navigate to "Advanced System Settings" -> "Hardware"

- Click "Device Installation Settings" and Select "No"

**This will prevent Windows from interfering with your hardware drivers in future updates, but keep crucial security updates rolling.

 

Step 3.2 - Uninstall Display Device with drivers and reinstall:

- Press the Windows key + X and select "Device Manager"

- Expand "Display Adapters"

- Right click the AMD, NVIDIA and/or INTEL VGA devices and select "Uninstall"

- If prompted to uninstall drivers associated with the device, tick the box and continue.

- Perform a restart of the laptop. 

 

Hopefully one of these will sort the issue,

 

Regards

 

Voithos

 

IamNived
Reply
Options

2 Posts

10-15-2020

India

4 Signins

5 Page Views

  • Posts: 2
  • Registered: ‎10-15-2020
  • Location: India
  • Views: 5
  • Message 4 of 4

Re:Legion 5i hybrid graphics mode issue

2021-07-02, 2:36 AM

 When gaming with hybrid mode turned on , I have huge frame drops. And its annoying to restart just to play a game every time. Is there a fix for it ? please help 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All