Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

2 Posts

08-29-2016

Denmark

5 Signins

47 Page Views

  • Posts: 2
  • Registered: ‎08-29-2016
  • Location: Denmark
  • Views: 47
  • Message 1 of 2

Lenovo Y50 WiFi button not working Windows

2016-08-29, 12:26 PM

Hello everyone, 

 

Since i got my Lenovo Y50, i have been having an issue rarely and i thought it would be better to try and fix it.

I have had it on Windows 8.1 and now on Windows 10 also, when i start my computer, WiFi works flawlessly, but if I try and switch to another network on open the WiFi networks tab on the taskbar, it might happen that it kinda "freezes", meaning that it shows either that WiFi networks availalbe or not available but when i click on it nothing happens. I mean it doesnt pop up the select WiFi network window. And also if during this time i try to go to Control Panel -> Network and Sharing Settings it doesn't open it. If i plug a LAN cable in it the internet works fine but the WiFi button still stays the same. Doesn't even change to the cable connection one. 

Also this sometimes happens when wifi is working but i notice that the icon changed to the above mentioned (WiFi networks availalbe or not available) and when i try clicking on the wifi button nothing pops up, meaning again i cant change the WiFi on disconnect. 

Funny thing is that every single time this happens, a restart fixes it. Every time so it really doesn't make sense to me and it baffles me that this can happen. 

I tried reinstalling drivers, looking for stable ones, etc. nothing helps. 

I will provide a picture with my device manager Network Adapters tab, i hope it helps.

 

Any oppinions are welcome.

 

Reply
Options

11 Posts

07-03-2016

Poland

15 Signins

209 Page Views

  • Posts: 11
  • Registered: ‎07-03-2016
  • Location: Poland
  • Views: 209
  • Message 2 of 2

Re: Lenovo Y50 WiFi button not working Windows

2016-08-29, 18:52 PM

Hi
You can try to update all drivers with slimdrivers-https://www.slimwareutilities.com/slimdrivers.php
I had another problem but instalation new drivers from slimdrivers helped my. In my opinion it could be also OS problem but I'm not IT expert. Remember to backup drivers before instaling new one.
And remember people are divided into those who do backup and those who will do it.
Good luck

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms