Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

8 Posts

07-07-2014

India

9 Signins

95 Page Views

  • Posts: 8
  • Registered: ‎07-07-2014
  • Location: India
  • Views: 95
  • Message 1 of 2

Lenovo Y510P doesnt POST when LVDS cable connected

2016-10-10, 6:18 AM

Hey guys, I am having a weird problem with my Lenovo Y510P, there's a LVDS cable which connects the motherboard to the lcd. When I disconnect this cable, the system boots perfectly and I can see the desktop when connected over hdmi to TV. However when I connect it back, the laptop doesnt even POST, no lights, no fans, nothing. I am unable to find the source of this problem, is it the LCD that's dead or some component on the motherboard? A short somewhere? 

Reply
Options

4770 Posts

12-11-2015

United States of America

4745 Signins

54592 Page Views

  • Posts: 4770
  • Registered: ‎12-11-2015
  • Location: United States of America
  • Views: 54592
  • Message 2 of 2

Re: Lenovo Y510P doesnt POST when LVDS cable connected

2016-10-10, 6:59 AM

My first guess would be a short in that cable since it probably gets flexed alot (if it is the one I am thinking of), and they are pretty cheap.

 

NEW LVDS CABLE FOR LENOVO Y510P 1080P FHD LCD LVDS CABLE VIQY1 DC02001KT00

https://www.aliexpress.com/item/NEW-VIQY1-DC02001KT00-LVDS-CABLE-FOR-LENOVO-Y510P-HD-1080P-FHD-LCD-LVDS-CABLE/2021628411.html?spm=2114.40010308.4.2.SPIqNy

 

Good Luck,

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms