Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics

4 Posts


United States of America

8 Signins

64 Page Views

  • Posts: 4
  • Registered: ‎02-09-2016
  • Location: United States of America
  • Views: 64
  • Message 1 of 2

Lenovo Z51-70 80K6 Won't Boot even into BIOS

2019-01-11, 2:17 AM

I'm suspecting a Motherboard problem.
It's the i5-52000u w/ R7 M360 AMD GPU.

When powering on, nothing happens for a while. A clicking sound is heard out of one speaker, at approx 1 hertz. Also the screen barely visibly flickers at the same frequency.

When problem first noticed, the machine would go through 20-100 of these cycles Before loading up "lenovo" sign, BIOS,etc , then progressively more.
I've tried combinations of booting with peripherals (VGA, HDMI, usbs, power cable) plugged in and not.

The amount of cycles the laptop goes through before finally loading the Lenovo screen, from which OS boot sequence starts, or accessible BIOS via num+f2, has been increasing, to the point of taking an hour.


I've opened her up to see if anything is poorly plugged in, everything works well. The thermal logic chips work ok, the HDD spins ok. But the BIOS and any boot sequence is inaccessible until it randomly starts working. Mostly I have to wait 30 min to an hour, but sometimes it's only 15 minutes.

It's probably the Motherboard, but I wanna know what failed/failing?

The laptop works flawlessly once the LENOVO logo shows up; i can access BIOS, etc.

This happens during a restart, an on- and off.

I've tried disconnecting the battery, and pulling the CMOS battery out and letting it sit for like 10 minutes.


Kinda sucky. Because it's probably some small voltage regulator or something that's super faulty.

At this point, the laptop is approaching three years old. Replacement Mobos are like $300 with soldered cpu and gpu chips. 

Took care of this thing like a baby, no drops, thermal infringements of any kind. 

Anyone having the same problem? Most people seems to have GPU burnout, or BIOS corruption. But I think it's the pre-BIOS sequence that experiences problems. 

I haven't yet reflashed the BIOS, because I do not think it's the problem. 



1 Posts


United States of America

3 Signins

20 Page Views

  • Posts: 1
  • Registered: ‎04-06-2021
  • Location: United States of America
  • Views: 20
  • Message 2 of 2

Re:Lenovo Z51-70 80K6 Won't Boot even into BIOS

2021-04-06, 15:06 PM

Yes, I'm seeing the same problem on my wife's Z51-70. "I" have gotten it to boot eventually three times after going through various mystical incantations involving F2, the Novo button, and chicken bones, but it alway comes to life after I've walked away from it. So I don't think I have actually done much to get it working--it's more like it gets past whatever retest loop it's going through internally. I've encountered many similar descriptions in different on-line forums, but no definitive answers. Looks like our future purchases will NOT be Lenovos.


Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop





No, I don’t want to share ideas Yes, I agree to these terms