Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Lenovo NotebooksLenovo P, Y and Z series Notebooks
All Forum Topics
Options

1 Posts

10-19-2013

Denver, CO, USA

4 Signins

22 Page Views

  • Posts: 1
  • Registered: ‎10-19-2013
  • Location: Denver, CO, USA
  • Views: 22
  • Message 101 of 256

Re: New y510p with a wifi problem

2013-10-19, 15:26 PM

For what it's worth, disabling Wireless-N through Device Manager seems to have fixed the problem for me. I realize that people with Wireless-N routers won't like that answer, but for those of us with B/G routers it's a quick fix. 

 

Subjectively, it does seem to be an interference issue. I didn't have a lot of trouble until my wife fired up her laptop next to me, and then my wireless basically died. Perhaps it's influenced by the channel selection? 

 

Reply
Options

4 Posts

09-04-2013

Miami

14 Signins

49 Page Views

  • Posts: 4
  • Registered: ‎09-04-2013
  • Location: Miami
  • Views: 49
  • Message 102 of 256

Re: New y510p with a wifi problem

2013-10-20, 22:05 PM

Guys, there is a definitly solution? i have been with this problem for 2 months, i cant play with normal...  Please i need an answer. Its a $1300 PC, guys a solution now please!... Its my third post here...

 

 

Reply
Options

30 Posts

06-28-2013

California

56 Signins

217 Page Views

  • Posts: 30
  • Registered: ‎06-28-2013
  • Location: California
  • Views: 217
  • Message 103 of 256

Re: New y510p with a wifi problem

2013-10-20, 23:09 PM

Unfortunately, there does not seem to be a perfect solution. By disabling the wireless-N setting, you may be able to solve part of the problem. It's problem with the N2230 wifi card. And Lenovo will not replace this card with another one that works. Or at least they have not offered that option yet. 

Reply
Options

30 Posts

06-28-2013

California

56 Signins

217 Page Views

  • Posts: 30
  • Registered: ‎06-28-2013
  • Location: California
  • Views: 217
  • Message 104 of 256

Re: New y510p with a wifi problem

2013-10-20, 23:11 PM
Breischl:

It's funny you mention that. I have noticed the same thing when my wife accesses her computer next to me, and I have also noticed when I turn my microwave on that my internet speed lowers. I thought it was my imagination at first---but I experimented a few times with the same result.

Changing a router's broadcast channel may help...
Reply
Options

4 Posts

09-04-2013

Miami

14 Signins

49 Page Views

  • Posts: 4
  • Registered: ‎09-04-2013
  • Location: Miami
  • Views: 49
  • Message 105 of 256

Re: New y510p with a wifi problem

2013-10-20, 23:27 PM

Wagraham, thanks, but do you know how to disable the N settings please...

Thanks!

Reply
Options

30 Posts

06-28-2013

California

56 Signins

217 Page Views

  • Posts: 30
  • Registered: ‎06-28-2013
  • Location: California
  • Views: 217
  • Message 106 of 256

Re: New y510p with a wifi problem

2013-10-20, 23:35 PM

Yep! Go to your control panel > device manager > network adapters > right-click on wireless card > properties. Once insise, you should see options with drop down menus. One of them will talk about N mode. Simply disable that. 

Reply
Options

4 Posts

09-04-2013

Miami

14 Signins

49 Page Views

  • Posts: 4
  • Registered: ‎09-04-2013
  • Location: Miami
  • Views: 49
  • Message 107 of 256

Re: New y510p with a wifi problem

2013-10-21, 2:25 AM

Thanks men!

Reply
Options

2 Posts

10-27-2013

edmonton, alberta, canada

6 Signins

14 Page Views

  • Posts: 2
  • Registered: ‎10-27-2013
  • Location: edmonton, alberta, canada
  • Views: 14
  • Message 108 of 256

Re: New y510p with a wifi problem

2013-10-27, 3:17 AM

Hi lenovo forums,

 

I just received my y510p on friday, and I'd been having wireless connectivity issues since.

 

I was able to download windows 8.1 and all of my steam games to the laptop, but the connection was mostly useless.

 

Following the directions in this thread I updated my centrino N-2230 wireless driver with the latest one, driver version 15.10.3.2 provided by Intel. This seems to have fixed the problem, at least for now.

 

I hope this helps anyone who needs it, and I hope that the lenovo engineering teams can produce a reliable, guaranteed fix for this if this solution somehow stops working.

 

Thanks!

Reply
Options

2 Posts

10-27-2013

Saudi Arabia

3 Signins

26 Page Views

  • Posts: 2
  • Registered: ‎10-27-2013
  • Location: Saudi Arabia
  • Views: 26
  • Message 109 of 256

Re: New y510p with a wifi problem

2013-10-27, 18:55 PM

Hi guys, I have the y500, and it has the same wireless card as the y510p. That being said i think i found a solution for the wifi issue. note that i a running W7 64bit service pack 1.

 

see the reply by victor in the link below on page 2 and change the settings according to his instructions 

https://communities.intel.com/thread/32017?start=15&tstart=0

 

Also please read through the thread for the Y500 connectivity issue for knowledge purposes: https://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/lenovo-y500-wi-fi-serious-problem/td-p/1092313

 

Victors approach worked for me - but also try changing the Security/Encryption Type of your wifi to  WPA2/AES.

 

hope this helps. i know its a very generic fix, but it worked more me and its better than waiting around for lenovo and intel to create a patch.

Reply
Options

10 Posts

11-12-2013

San Diego

10 Signins

55 Page Views

  • Posts: 10
  • Registered: ‎11-12-2013
  • Location: San Diego
  • Views: 55
  • Message 110 of 256

Re: New y510p with a wifi problem

2013-11-12, 18:21 PM
Link to the driver that Intel claims fixes the dropout issue?
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms